Pokemon Y and Ultra Sun Freezes but sound and inputs still works, black boxes appearing

Issue: My copies of Pokémon ultra sun and Pokémon y just randomly started freezing and before it freezes weird black boxes show up and it’s on the top and bottom screen and sometimes when i try to save so i won’t lose progress Citra crashes and it closes itself.

Enter a description of your issue here, in full detail.

System Information

  • Operating System: Windows 11

  • CPU: Intel® Core™ i5-1035G1 CPU @ 1.00GHz

  • GPU: Intel® UHD Graphics

  • Citra Version (found in title bar): 1737

  • Game: Pokémon Ultra Sun, Pokémon Y

  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (418.1 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1737 HEAD-28039d3
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz | AVX512 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            30.0.101.1191
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Please try out a portable Citra build to rule out any issues with Citra’s current installation:

Go to Download Citra - Citra and select Manual download. Then under Nightly Build, click on your operating system’s icon to the right of the latest build available to download the build.
Extract it (.7z can be extracted using Winrar or 7zip) and put it where ever you wish. Inside the extracted mingw folder, create a folder called user. This Citra should now store all of its config, save files and such inside of this user folder.
Check to make sure that this user folder is in the same folder that contains citra-qt(.exe)
Now run the citra-qt executable found inside of the mingw folder and run your game. If the sam issue occurs, upload a log file using this portable build.

Ok thanks! I’m going to try it! If it works ill, click the check mark!

Ok did the user file and everything to run citra and im gonna add my saves

Don’t add your save files or anything else. You’re just including more variables we don’t need whilst testing.
Just run your ROM and see if the issue remains, if it does, upload a log file. If it doesn’t, add your save file and see if the issue returns.

Oh ok!
Does it count if i removed the saves? Because I just removed them

Also the games did the same thing games fps looks likes it stops but sound and input still works and black boxes show up. so heres my log file:
citra_log.txt (5.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try installing these according to the instructions given in the same link: Visual C++ Redistributable Runtimes All-in-One (Dec 2021) Download | TechPowerUp

Just did what do these do?

Hey again! I’m just asking you want did these do so I’m asking again did the stuff I downloaded do?

Those are dependencies. They usually already all come with Windows itself, but there are exceptions. Those exceptions could possibly cause the issue you were describing so I thought it would be a good idea to install them again for sanity’s sake.

Oh ok!
So, when can get back to troubleshooting?

You never mentioned whether updating the dependencies had any effect?..

Oh, ok I’ll try it give me a minute.

So far, the game is running great! No black boxes, no freezes.

Awesome. If you encounter the same issue again, make sure to upload another log file for me to look at.

Ok! I think the issue is fixed! I will make sure to send you a log file when the issue comes back!

Hey it’s me again! My Citra is having the same issue again so im going to send you the screenshot and the log file:
citra_log.txt (43.3 KB)