Pokemon Y cant speed up game

When playing pokemon Y (or really and 3DS pokemon game) i cant speed the game up. Last night it seemed to work when I unplugged my power cable but that is no longer the case. Also the game will speed up when i minimize the citra window. I can tell because the music gets a lot faster but as soon as i try playing again it stop at 100% speed

System Information

  • Operating System:
  • CPU: Intel Core I5-8300
  • GPU: NVIDIA 1050 TI
  • Citra Version (found in title bar): 1874
  • Game: Pokemon Y/OR
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt.old.txt (32.0 KB)

In order to save a copy of the log, follow this guide:

Additionally, my emulator was working fine until yesterday prior to citra 1873. Also, I have since tried uninstalling and reinstalling citra to no avail

Please try the latest Citra Canary build.

huh, weird. That instantly fixed it. Any idea why? Thanks a ton btw!!

V-Sync issue. We’ve reworked a bunch of Citra’s graphical backend recently, and the changes included V-Sync. However, that also created some regressions. So there’s a PR in Canary that attempts to address those issues.

hey snake, so i just updated again tonight to canary 2450 and the same issue is happening. any idea?

Go to Emulation>Configuration>Graphics>Advanced Tab and disable V-Sync (not possible whilst the game is running).

That seemed to help a ton thanks! Still not as smooth as it was when you helped me fix it last time but id say its probably at a 90% fix. Thanks for the support!