Pokemon y running slow

Issue:
Enter a description of your issue here, in full detail.

System Information

  • Operating System: Windows 10
  • CPU: Intel core i5 2450M CPU @ 2.50GHz
  • GPU: IntelHD 3000/ AMD Radeon HD 7400m seires

citra_log.txt (56.4 KB)

System Information for Support

Client Version                                Nightly 1644 HEAD-2d972f9
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon HD 7400M Series
GPU Driver Version                            15.201.1151.1008
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

here is my RAM as well,

RAM: 6 GB

is it the GPU, CPU, RAM or all of them that are bottlenecking me.

Please try running citra on your iGPU instead of your dedicated GPU. Then upload a log file afterwards. Let me know if you need help on how to do so.

citra_log.txt (4.9 KB)

System Information for Support

Client Version                                Nightly 1644 HEAD-2d972f9
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

when i try to run it on the Intel HD its says it doesnt support OpenGL

Ah my bad, I should’ve known that Intel HD Graphics 3000 doesn’t support opengl 3.3.
Run it on your AMD Radeon HD 7400M again.
You can try disabling Hardware Shaders in Emulation>Configuration>Graphics>Advanced Tab. That seems to boost the speed a bit in some games when using AMD GPUs.
However, it might just be that your hardware is just not up to it. Especially because you’re using an AMD GPU which have horrible opengl drivers (which citra uses to emulate), causing performance to drop massively.
The only thing you could do about that is dual booting into linux and using citra linux to take advantage of linux’s superior opengl drivers for AMD GPUs. That’s if you’re willing to go through the trouble of figuring out how to do that just for citra.

i disabled hardware shader, when from 16 to 28 FPS ingame so that helped, ill probably stay on windows but it is running faster now. also is there away i can try to use the cpu to help with speeding it up, becuase i checked the 0 core usage and it was only at 45-50 % and 2.23 GHz usage.