Poor FPS with Pokemon Sword - 10-20 FPS on Intro - Early Access Multicore

Hi!!

After this new update which includes multicore, I really had expectations even if my intel processor is kind of old, is a i7 930… Well, I know is old, but I resist to thing that after this multicore update there’s not enough threads and performance to run at least 25-30 FPS, Im not looking for those huges performance with High-End PCs, but 25 FPS?? Come on!!

My graphic card is GTX 1080 which I think is ok… I saw on videos with this graphic card and reach really good FPS, im realistic about FPS, but I think 25 FPS stable is not much to ask!! Or it is??

I would like to know where is the neck Bottle. RAM is not at full, Processor is also calm, and Graphic card the same…

¿Can you help me?

I heard about give logs… Tell me what you need and how to do it…

Thanks in advance.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

The game is a fixed 30FPS one, you are reaching 83% of the normal speed, on a 10 year old CPU.
Wait for future optimizations.

Hi,

I will provide you logs.

Well, thing is… FPS drops with frequency, like, 5 FPS, then get higher to 10, then 15, 20, and 21 at most, and the best situations… but I was talking about intro… But once, we are at home, at first scene, suddently FPS drops until 2-5 FPS, when pokemon with the boy appears… I think is too slower since the Multicore update even with my cpu and gpu.

I dont know if this is normal, but I would like to be completely sure.

I will provide 2 logs.
Config1 with no mods and Shared Cache.
Config2 with mods to improve performance, Update 1.1.1 and Big shared Cache.

I follow different guides trying to get the best.

Wait 20 minutes and I will upload

yuzu_log_Config2_part1.txt (1.9 MB) yuzu_log_Config2_part2.txt (3.0 MB) yuzu_log_Config1.txt (548.9 KB) yuzu_log_Config3_NullAudio.txt (3.4 MB)

Config 1 - Just ROM with no mods or shaders cachés. Vsync Activated
Config 2 - First time Shader Cache is load, this means need to load all first. Thats why i split in 2 parts - Mods with update 1.1.1 and fixing textures
Config 3 - Same, Shader Cache already loaded but adding Audio to null.

I hope this could help you about my system and possible fails that could slow my setup.

NOTES:

I wanna add… Something that caugh my attention is that, there’s no almost differences when i put a config with some high setups. Vsync was deactivated on config 2 and 3, but wasn’t really too much differences.
Let me know what you find.

That sounds like shader compilation, that’s normal. Shaders have to be translated to something your GPU can understand in real time, and any action, scene, effect, character, etc will trigger a new one. The solution is to keep building the shader cache by playing, and a way to reduce the amount in Pokémon Sword is by disable battle attack animations.
In the future we are trying to implement ARB shaders, that will reduce the shader compilation lag to almost nothing.

Also, in the past few days I’ve noticed and reported performance issues in CPUs without AVX2, I hope we get a fix for that soon.

Hi,
Thanks for your answer… I tried all combinations possible… As you said, it make sense that shaders could affect, but i tried with and without them…

Anyway, if I understand well are you saying that as more as I play performance are getting better due the shaders caché?? Will you recomend me not having one, and wait the own game created it?

The thing is… I just cant understand the drastically drops… for example, once the intro is over and the boy is sitting at couch, the guy with the pokemon, that scene makes drops until 2-3 FPS this is too much and I just dont thing is about my CPU, intro scene also were heavy and didn’t drops as much as 2 FPS. The game still with those 2-3 FPS for long time, actually I stoped to play at this time…
Well is a pitty but have sense about the AVX2 which my processor doesnt have but could be a good reason, its a pitty because i heard it was not long time ago that it was implemented.

it sounds good, looking forward for this new features and news… let me know if there’s something i can try to improve the performance that you could know in the maintime.

Thanks…

If you have “Use Disk Shader Cache” enabled, you build your own cache as you play.
Regarding performance, if you follow this guide to set up the Nvidia Control Panel, and run yuzu as administrator you should get a nice performance boost: https://www.youtube.com/watch?v=omRFhicsLw0&t=978s
This only applies to OpenGL.

Hi GoldenX86

Actually i did this thing wanting maybe to increase the performance, but no a thing or FPS increase, well, maybe one… hahaha.
The thing I didnt try or i couldnt see on video, is run yuzu as administrator, could this make the difference??

Will see… I will try.

Cheers, and thanks again.

Nah, its weird.
No a bit of performance boost, that im really piss off. I cant understand this situation. in-game FPS are as low as 2-3 FPS, increase when i stop running. but then when the guy is stopped almost at the point to save the game, is also slow, the boy is not moving and it seems similar to the intro, but, in intro i reach 13-20 FPS which under circunstances is not bad.

There’s something wrong or bad manage to take advantage in old cpu’s. Probably the well use of AVX to boost performance and my cpu didn’t have it could be something…
I also see that when boy is moving and FPS drops memory are at 88%, probably CPU is at 66%. I would like to know if because ram is getting close to running out of memory it could affect to the performance?
I have algo a 16.000 MB of pagination memory and my HDD is running at a SSD.

Due all this issues, i tried with the other emulator which have a lot of visual glitches, but well, even not being as optimiced as yours i reach a 7-14 FPS at the same circunstances.

any help would be appreciate, but i just dont wanna change my cpu, due i thing we are on this period of technology consumption which i denied to follow. I know my graphic card is not happy to reach the max FPS, but reach enough FPS to play good 40-60 FPS with quite enough high settings.

You did a lot of good work with multiCpu but… hahaha curious that my cpu is not taking advange of this, and i dont thing either are getting the brutal performance of high-End pcs.

Nice work… waiting for your feedback about if RAM or other factors could affect or impact on performance.

Note: Also, i forgot to mention, a put texture as low in my nvidia card to improve the performance above to quality, but no differences. I think theres a really bad management of resources because quality emulation already beat them all.

Well I reply myself with the last test i will do with this early version 558

Critical low FPS (1-4) - boy is walking running in his house:

RAM: 60%
CPU: 30-50%
GPU: Is taking a nap 5-13%

Recovering FPS (15-18)- when boy stop, FPS increase but just a little time, them again drops (1-4 FPS)

RAM: 60%
CPU: 40-60%
GPU: working a litle 20-40%

Thing is curious… why when a boy is stop CPU is working but just momentally, but when is running gpu is taking a nap and cpu is used at less of half capacity?

There’s something then wrong about resources and graphic management. Is inside of home… There shouldnt take too much resources… I understand the dificulty of management of wild zone which there’s a lot of things going on… but inside the home??

hahaha tell me is this is wierd or not.

Also I have to say I’m connecting to this pc remotely home network, but could really affect that much to the performance, and… if it does, why CPU, GPU and RAM are not actually performance better?

I attach screen captures.

Hi, just for testing purposes.

I decided to also try with the other emulator available… I can see… this time is taking more advantage to the processors and give more credit to the graphic card, anyway, it seems this emulation thing is more about cpu than graphic card. Im sure, with low graphic card but great processor emulation will be even better.

Thats why I will test my parents pc that recently they bought: AMD Ryzen 3 2200G/8GB/240SSD

For testing purposes I will see what happen then… But as I could anticipate, if Im right with all the performace tweeks I already learn, I think I will se how this machine beat my monster graphic card!!! hahaha

I know… is amd but… Well we see this video and with yuzu 177 is getting a good performance, imagine yuzu early…
Vulkan is not that bad how people think… using one or another… I didnt see really differences of performance with my intel.

So yeah… processors make de difference in this case… graphic card goes to second priority.

Comparatives:
https://technical.city/en/cpu/Ryzen-3-2200G-vs-Core-i7-930
https://cpu.userbenchmark.com/Compare/Intel-Core-i7-930-vs-AMD-Ryzen-3-2200G/m79vsm441832

Graphic Cards

Hi!!
I could see there’s a new update… Well surprisingly improves a lot the framerate on start screen… I reached a really good FPS… more than expected.
But, still in game there’s a lot of problems, practically the same, but, there’s a minor FPS improvement when boy stops, 1-3 FPS, its a big deal of improvement.
I still dont know why it drop that much when boy is moving.

Start Screen - 48-51 FPS
In-game (Boy Walking) - 1-3 FPS (Sometimes is not moving from 1 FPS)

ScreenShots

Yeah your problem alligns with what I saw on previous owners of old CPUs. We’re investigating it, this started to happen very recently.

Hey guys, just bump this thread to say that I have the same issue Lutape have on Pokemon Sword everytime theres animation happening to the main character (maybe on others character too) the FPS drops from 30fps to 1-3fps it seems this only a problem with pokemon cause others game my computer can run at pretty steady framerates hope you guys can solve this issue, heres my computer specs.

OS: Win 7 64bit
Processor: Intel® Core™ i7-3770K CPU @ 3.50GHz (8 CPUs)
Graphic Card: Nvidia GeForce GTX 1080
RAM: 32GB

Build 610 from early access and still no advance about the old CPUs issue drop FPS suddently. Is really a big deal, and a bad development. Is weird and this happen only with this emulator as I showed previously.

Screenshot:

We will have to wait a little longer…

By the way, Hi Klais, thanks for commenting, is good to have a good feedback and that there’s a lot of more old CPUs that have this problem.

The ones who are experiencing similar issues, please report here.

Cheers.

Hey guys ,I have the same issue on my PC.

Processor Intel® Core™ i7-4820K
Graphic Card GeForce GTX TITAN Black
RAM 16 GB

I have 30 fps on start screen ,in game when the boy don’t move I have around 20 fps and if he starts moving I drop to 1-3 fps.

I tried to run yuzu on my laptop

Processeur Intel® Core™ i7-4750HQ
Graphic Card GeForce GTX 980M
RAM 8 GB

And it work perfectly the game is always around 25-30 fps.

On my laptop the processeur have AVX2 but not on the PC.
Hope a new update soon to fix this issue.

Your desktop CPU is an HEDT Ivy Bridge, so it lacks the AVX2 and FMA instruction sets. Expect poor performance on it.
Your laptop is a Haswell one, and has those instruction sets, that’s why you get a far better experience.

I am felling sorry for GeForce GTX TITAN Black with that CPU, this is your bugs with that CPU.
01xzvquc7

Can you guys help me with my issue on the import of a game cartridge? It seems you got your pokemon sword to work