Port Forwarding and connecting to your Citra server

#1

Hello there ive created a room, after ive already port forwarded successfully through my router settings. Made a bat file to keep the server up and running, but… i can’t connect to the room directly, meaning that i can only use “Direct Connect to Room” to get inside but only me. Friends though not only cant get in by just double clicking(like i cant either) but also cant connect using the “Direct Connect to Room” either. The error thats giving is this

EDIT: And looking at the citra server list it shows like this

Imgur

There is no visible grey arrow next to the server

1 Like
#2

Check if your firewall or antivirus isn’t blocking citra-qt.exe and citra-room.exe.
also on your router settings try using a port range from citra’s default port, 24872 + 16, i.e: 24872-24888. also make sure that you are assigning your computer ip to your port forwarding settings (if required).

#3

Ok will do thank you

#4

Ive checked everything you proposed still gives me the same error :slightly_frowning_face:

#5

I am with the same error I can not create public rooms people can only connect directly by ip

#6

Does that occur only when using citra-room? does it also happen by using Multiplayer > Create Room?

#7

Hi, I have the same error. I can create the room but nobody can join it.
But if I can join locally from another citra.

#8

I showed both instances of having the same issue. So yea