Pro controller not detected anymore in Citra (M1 Macbook Air)

Hey guys, have been running Citra nightly 1587 on my base M1 macbook air and has been working pretty well, except all of a sudden its no longer detecting button presses from my Nintendo Switch Pro Controller connected via bluetooth? It was working previously and I’m not sure what broke it. Unable to even configure the controls anymore. Have tried the current nightly/canary versions and same behaviour. Not sure where to start or how to troubleshoot.

System Information

  • Operating System: MacOS Monterey 12.1
  • CPU: M1 2020

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

As stated on our downloads page, we do not provide support for M1 MacOS devices.

I understand that there won’t be any official support, but I just wanted to add a me-too here. After not playing for a week when I went to use Citra my Switch Pro controller has stopped working. I tried un-pair and re-pairing it. I’ve also tried a USB cable.

Very bizarre but you’re not alone @jimzzor1991 !