Problem for create public room

I can’t create a public room
An error window appear with
“Failed to announce the room to the public lobby. In order to host a room publicly, you must have a valid Citra account configured in Emulation - > Configure - > Web. If you do not want to publish a room in the public lobby, then select Unlisted instead.
Debug Message: 400”

I have verified my username and my token everything looks good

System Information

  • Operating System: Windows 10 Professional
  • CPU: Intel ® Core ™ i5 - 7600L CPU @ 3.80 GHz
  • GPU: Asus GTX 1050Ti
  • Citra Version (found in title bar): Canary 994
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (3.4 KB)

In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Open the qt-config.ini file on C:\Users\%username%\AppData\Roaming\Citra\config and look for the section, does yours looks exactly like this? (if you want to comment yours here don’t forget the erase your token from the comment):


I have enable_telemetry\default and enable_telemetry set to true
I don’t have telemetry_endpoint_url=
Is this normal?

I set enable_telemetry\default and enable_telemetry to false and it works

is it working now? btw, its best to delete all of those field (that entire highlighted text of my previous comment), save the file and open citra, they will be properly regenerated, then you have to input the username and token again.

do that and see if it works with telemetry set to true, which helps citra development.

After delete those field and save the file, i open citra and input username and token.

It works with telemetry set to true.

1 Like

I am getting the same 400 error. I tried setting telemetry to true, but it doesnt work. i have tried on windows as well as mac.

I have a weird error. Mine says credentials needed even though I have verified my token multiple times. I even tried the above method to no use. Can someone help me?

Click to verify your credentials and try to connect to a room, close citra, now try to create yours.

We made a server-side update last night which deprecated some old authentication mechanisms.

Please upgrade to the latest version and try again?
Does this resolve your issue?

Yes it did. Thank you so much guys! Keep up the good work :slight_smile: