Problem in TLOZ: Ocarina of Time 3D

Issue
In the game The Legend of Zelda: Ocarina of Time 3D, I have a problem in the part of the visions, I have low FPS in the game, around the 37% to the 41% of the velocity in total (100%). This is problem of my PC or the emulator??

System Information

  • Operating System: Windows
  • CPU: Intel® Pentium® 3.00 GHz
  • GPU: Intel® HD Graphics
  • Citra Version: Nightly Build-7fa2076
  • Game: The Legend of Zelda: Ocarina of Time 3D

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (67.4 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

And how much time I wait to the moderator for the assistance???

disable ‘Enable Hardware Shader’

your cpu and gpu is slow, try changing the gpu to nvidia or amd

I also have lag issues however they appear ONLY if I looks at the sun, which is strange cuz before I made 2nd save file I was looking at the sun and FPS was ok

Hi, i got the same issue the only weird way i found to “fixe” it is to lower the CPU clock speed (for me to 20 %) when i go to the visionn stone idk what cause the issue, i have a old proc (I7 3770 3.40Ghz)

I have this issue on Ryzen 7 3700X. The lowering of the CPU clock speed to 20% worked, but the game randomly freezes after returning to the 3D main game, so it’s pretty unusable, sometimes even freezing the whole Citra application.

Turn it to around 50% instead then. Go to 75% if you’re still experiencing freezing issues.

I just tried it. Didn’t help. The increase of CPU clock slows the video playback and the freezes still occur, whether at 50% or at 75%. The emulation then stops and must be restarted in order to continue.

Just checking to be sure, but are you increasing the CPU Clock Speed by 50-75% or are you underclocking to 75-50%?
You need to be doing the latter like this: afbeelding

Yes, that’s exactly what I did.
Without the downclock I get 3-4 fps in the Visions.
image

At 20% I get 29-30 FPS but the game randomly freezes,
at 50% 10-13 FPS which is still pretty unusable on top of the freezes still ocurring.

Please upload a log file. Maybe there are some other sub-optimal settings we can tweak to get some extra performance: ```

Okay, here is the log citra_log.txt (206.0 KB)

System Information for Support

Client Version                                Nightly 1694 HEAD-e6c479f
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 3700X 8-Core Processor             
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1080 Ti/PCIe/SSE2
GPU Driver Version                            461.40
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Thanks @CitraBot for an obvious observation :wink:

I can see you have both custom textures enabled and have upscaled 6x. Try disabling the custom texture and put the internal resolution down to native in turn and test whether they cause a significant performance drop during the visions. I’ve heard that underclock freezing can be affected by custom textures in particular. So it might be good to test underclocking without the custom textures on.

Okay, I’ll try the native resolution. The custom texture pack I added only an hour ago, so I can that out of the equation.