Problem when trying to start a game

Issue: Games wont work at all- I’ve spent a good few hours trying to figure out the problem, including looking through the forums etc, I can’t seem to find an issue identical to my own.

System Information

  • Operating System: Windows 7 64bit
  • CPU: I7 4790k, 4ghz
  • GPU: GTX 1070
  • Citra Version (found in titlebar): Citra Edge, Citra Nightly (Same on both)
  • Game: Pokemon Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Log: [ 0.000000] Frontend citra_qt\main.cpp:BootGame:374: Citra starting…
[ 0.779179] Service.APT core\hle\service\apt\apt.cpp:Init:673: Unabl
e to load shared font: C:\Users\Digit\AppData\Roaming/Citra/sysdata/shared_font.
[ 0.780593] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cp
p:Init:490: GL_VERSION: 1.1.0
[ 0.780733] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cp
p:Init:491: GL_VENDOR: Microsoft Corporation
[ 0.780850] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cp
p:Init:492: GL_RENDERER: GDI Generic
[ 0.780971] Render video_core\video_core.cpp:Init:35: initialization f
ailed !
[ 0.781074] Core core\core.cpp:Load:85: Failed to initialize system
(Error 7)!

your gpu does not support opengl 3.3 which is required for citra.

i see your vendor is microsoft which means your drivers might be wrong, i suggest trying to download official drivers from intel/amd/nvidia

Download the correct drivers from the official Nvidia site:

This says it supports 4.3, I’m making the assumption it’s compatible with older versions.

I updated my GFX drivers before making my post. Shows I’m on the latest NVIDIA 381.65.

citra might be trying to run on the integrated gpu (intel) which might not have a driver installed to begin with, not sure how but see if you can get it running on your nvidia gpu through some options

You’re talking about HD Graphics here. Your GPU supports up to 4.5

Interesting issue. The GPU drivers are installed, but Citra doesn’t see them? Try running DDU and reinstalling Nvidia drivers.

@RavenHome [quote=“RavenHome, post:5, topic:1375”]
but see if you can get it running on your nvidia gpu through some options

This is a desktop, not a laptop. There are no switchable graphics here.

1 Like

Run DDU in safe mode, clean uninstall of the GFX drivers, then downloaded them again off of Nvidia, installed them- still the same issue. I’ll be honest, I thought that’d work.

Well I certainly feel stupid- I was creating a custom resolution a while back & I must have accidentally switched the color depth to 16bit, this apparently didn’t mess with anything else except applications that used OpenGL & seeing as I don’t use or play anything that made use of OpenGL I didn’t immediately notice.

You can also switch the GPU on a desktop…

Desktops don’t work that way… Either I have never seen that (I fixed like 25 desktops over 2 years), or that doesn’t exist.

It’s the integrated graphics or the discrete GPU. Laptops have a function, called Nvidia Optimus / or AMD equivalent, which can switch between IGP and GPU.