Problem with fire emblem awakening dlcs

ok i was playing fire emblem awakening On my phone and everything ran excellent, both the game and the dlc were recognized by the emulator on Android but when I tried to play any map, it only took me to the first map, it doesn’t matter If I choose the last map or the second or the first it only takes me to the first map, I tried changing the region of the emulator, changing the rom or the dlc files, and the result is always the same, it should be noted that I was able to play fire emblem awakening and its dlc perfectly with this exact phone a year ago it’s a poco x3 pro

Operating System: Android 11 +Miui 14
CPU: snapdragon 860
Citra Version (found in title bar): canary-2519
Game: fe awakening
Screenshot of Issue (include the full Citra window including titlebar):

citra_log.txt (23.4 KB)

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

I have this exact same issue. I’ve been searching for 3 hours at this point so if anyone knows how to solve please let me know

Are you still looking for a solution? I found one, if you want help dm me on discord CraftyDuck100#9880

Your screenshot appears to be from an unofficial build. Please double check what Citra version you’re having this issue with.