Problem with pokemon ultra moon for graphics glitch

Issue:
I have problems in pokemon ultra moon, in the whole game from the beginning the text is not very noticeable and I can not see the game menu.
How could I solve it? :frowning:

System Information

  • Operating System: windows 10 enterprise
  • CPU: Intel(R) Core™ i7-4600U CPU @ 2.10GHz, 2701 Mhz
  • GPU: Intel(R) HD Graphics Family
  • Citra Version (found in title bar): 1708
  • Game: Pokemon Ultra Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (16.9 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1708 HEAD-e7671d9
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4400
GPU Driver Version                            20.19.15.5126
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

it may be that your game its encripted, but by an unkow reason your emulator or rom its glitching, and it let you run the game, but the game its still encripted so it starts to glitch, its cause iv’e found a part in your log that says, secure key 1 missing, Part of this comment was edited by a moderator

try to use this AES Keys - Citra

if you have any concerns just tell me ok? you can read them there

Encrypted game files cannot ‘‘glitch out’’ and then run. That doesn’t make any sense. An encryption also doesn’t cause graphical issues, it causes launch issues (if you don’t have the decryption keys for it).

NCCH is marked as encrypted but with decrypted exheader. Force no crypto scheme
^ This line also states that no decryption key is necessary for running the ROM as it’s already decrypted.

Your iGPU has issues with the Accurate Multiplication setting. Disable it in Emulation>Configuration>Graphics>Advanced Tab.

Thank you! That helped me a lot! :smiley: