Problems on Mac

Enter a description of your issue here, in full detail.

System Information Mac 10.11.6 El Capitan

  • Operating System: OSX
  • CPU:
  • GPU:
  • Citra Version (found in titlebar): Nightly Build
  • Game: Pokemon Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Paste your entire console window log here.

In order to save a copy of the log, follow this guide: How to Upload the Log File

Ok, Im not really a computer person. I just wanted to play the game. I was able to do it at first but then i apparently changed something and now Citra wont start. It keeps doing what you can see in the image and it doesnt stop. It doesnt load.

Can someone help?

i’ll have to take a look into fixing the issue. a workaround can be found here

read that thread for more details

The thing is I cannot even open Citra to do that. It blocks everything and I’m obliged to force closure of Citra.

What? Clearly Citra is running for more than a minute in your screenshot. It’s the window to the right.

Learn how to use a computer.

Focus the Citra window and use the menu options in the upper left.
But I think that if you can’t operate a PC, then you’ll have trouble dumping your games properly.

Please reread my link again. It does not involve opening citra. The issue is with a bad default value on mac for the “game folder” directory and it tries to scan your entire hard drive for games. In that link I gave instructions on how to fix it without opening citra.

Citra is frozen and the only option is force quit. This is because of a bad default setting for game folder directory causing citra to scan the entire computer for games. Actually scanning the games is done on a background thread, but setting up the folder watcher is done on the ui thread meaning it blocks until it atleast looks over each folder. This is an issue for people with big game folders and apparently on mac when the default setting is bad.

(Edit: Moving the initial scan to set up folder watches off the UI thread turned out to be way more challenging than initially thought.)

1 Like

Citra opens but in instantly gets stuck. Maybe I should do a video only for you, in order for you to see I cannot access any part of Citra when it opens like that. I cannot close it, or access preferences or anything. The Mac rainbow wheel doesnt let me do anything.

And please, learn to be respectful. Your awful manners really dont help anyone in any way.

1 Like

So there’s no way to fix the problem? I tried what you said on the link but theres no folder with that name on my computer

Scroll down and read the rest of the thread and you’ll see that someone corrected me on the folder locations and the exact text to type. My mac has been out of commision for months now so I had forgotten the exact details when I wrote that. Perhaps I should edit my post for clarity

1 Like

I used what the other person said, I had already seen all of the thread.

There’s nothing like that on my computer.

Is there a way to download Citra again as if it was new? Ive been trying but it doesnt work, it keeps doing the same thing.

Yesterday when I tried the game it worked at first, but when I tried again this happened.

The details are kinda scarce, so I’m just taking guesses, but did you use the Go to Folder like I mentioned in my post? The folder is in a hidden location meaning you won’t see it in Finder. (On macOS, and folder that begins with . is a hidden folder)

Citra stores its configuration files separate from the application like most every application does these days. The problem is your configuration file is corrupted and needs to be fixed. I’m 100% positive this is the issue as thats exactly what those log messages mean.

Thats because its a misconfiguration. When citra first loads, it doesn’t have a config file so it generates one. And then you use citra like normal. The second time you use citra, it loads the bad configuration file and gets stuck trying to scan your computer for games. I’m trying to help you manually open the configuration file and change those settings so it doesn’t freeze.

Finally done! Thank you so much and so sorry for being so “slow”. Im used to emulators being very straightforward lol.

Again, thank you. Let’s see if it keeps working fine!

1 Like

Using citra usually is very straightforward. Usually :stuck_out_tongue: This is just a bug that was recently introduced (by me :frowning: ) that only affects a small portion of users. I apologize for the inconvenience. I’ll try again to fix the issue (but we’ll see how that goes as its actually kind of complicated)


FYI this issue should be resolved in the version of citra thats building right now (just stopping by to update this old thread with the news)

is it possible to see the game save files because im playing pokemon stars and the alolan photo club has a bug and the only way to skip it is with PKHex and i need to find the save file. Please help

This is offtopic. The issue with alolan photo club and pokemon league have been fixed in Canary for a while now and was merged into Nightly a few days ago. If you are still having issues, please create a new support topic.