Problems with no words displayed in games

Hello.

Please see attached image link.

Before YUZU 22, I could see Korean words in a game named legend of Zelda: link’s awakening. But I can’t do it after YUZU 22.

When I played the game again before yuzu 22, I got a text message.

What’s the problem with this?

before yuzu 22
Imgur

after yuzu 22
Imgur

Please let me know your advice.

Thanks.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Attached the log file below.
yuzu_log.txt (2.4 KB)

System Information for Support

OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable CPU JIT                                null
Docked Mode                                   [x]
RNG Seed                                      [ ]
Use Accurate GPU Emulation                    [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I’ll do a dump of the original Switch’s fonts, that would work.

In other games, Korean displayed good. But only the legend of zelda: link’s awakening did not display Korean alphabet after YUZU 22 even if use the original font or the other fonts.

If use the YUZU 12 or before YUZU 22 version in the current state, the Korean alphabet will be displayed.

Of course English is well displayed after YUZU 22.

I think it is not possible to display a language that uses 2 bytes per letter in the Zelda after YUZU 22.

Test 6 language configuration
English = displayed (1byte)
Dutch = displayed (1byte)
Canadian French = display (1byte)
Japanese = no displayed (2byte)
Chinese = no displayed (2byte)
Korean = no displayed (2byte)

I don’t know It is what problem but in YUZU 29, all languages were normally displayd!

Thanks.

I believe in yuzu 414, this problem appears again for at least Chinese.
English is perfect. Is it still the issue about byte width that @dumpling mentioned?

I’ve tried to put shared_font.bin under %yuzu_path%/sysdata/ but that doesn’t help

Chinese:


English:

Can you post a log file after a minute of gameplay?

Might be able to do that tonight (EST).

yuzu_log.txt (814.8 KB)

I think the errors are like this format:

HW.Memory <Error> core\memory.cpp:Read:644: Unmapped Read8 @ 0x00000038
HW.Memory <Error> core\memory.cpp:Read:644: Unmapped Read16 @ 0x0000004E
HW.Memory <Error> core\memory.cpp:Write:686: Unmapped Write8 0x00000004 @ 0x0000000000000038

But not sure about the specific reasons.

The shared_font.bin I dump my own is 17.0MB, I compared with other’s dump file online, and they are exactly the same.
I put it at %yuzu_data%/sysdata/, not sure if this location is already outdated.

Does it work if you move the font dump, if you use the generic ones provided with yuzu?
Also, increase your page file to 20000MB: https://www.thewindowsclub.com/increase-page-file-size-virtual-memory-windows

Sorry for replying late. I didn’t receive any email notification and find your reply until I manually check the topic.
I’ve tried both with that shared_font.bin and without it. But neither works.
And I just tried the 20GB page file and it doesn’t work either.

I think it’s not a problem with memory issues. My computer:
CPU: 9700K
GPU: 2080
Memory: 32 GB DDR4

The recent update of yuzu seems combines the NVDEC video decoder and it shows the open scene without unimplemented ioctl errors. While it still remains flickering as 4728 shows.

yuzu_log.txt (387.8 KB)

Have uploaded and it seems I can only reply 3 messages under a topic due to the new user limitations… @GoldenX86 Maybe move the issue to Yuzu Github?

Fixed by putting firmware NCA file in [yuzu_folder]\nand\system\Contents\registered.

Can you upload me a fresh log with the most recent yuzu version?

tried to play link’s awakening in Korean and had the same problem as Dumpling. I followed what Ren_Pang did. It worked like a charm.

1 Like