Project X Zone 2 blacked screen

PZX2 is running but in a totally blacked out screen, FPS is fine and sound works as well. Tested on two nightly builds.

System Information

Diagnostic Log.
citra_log.txt (1.4 MB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1547 HEAD-213c956
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Celeron(R) N4000 CPU @ 1.10GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics 600
GPU Driver Version                            23.20.16.4936
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

GPU Driver Version: Build 23.20.16.4936

This driver is outdated, you need to update.

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed that download and install igfx_win10_100.8190.exe from: https://downloadcenter.intel.com/download/29557/Intel-Graphics-Windows-10-DCH-Drivers?product=128988
direct link: https://downloadmirror.intel.com/29557/eng/igfx_win10_100.8190.exe

Also do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder(if it’s there)
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication and Shader JIT.

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

1 Like

Thank you. Worked like a charm.

1 Like