Project X Zone 2, superlags when entering combat

citra_log.txt (42.2 KB) Issue:
I was playing normally until Chapter 3, when any battle takes place the speed instantly goes 2%/100% and lags forever with the sound lagging too (even the pc did the same moments later). It never happened to me playing Citra with any other game.
I both a save file and a save state and both failed.

I really hope you can help me guys!

System Information

  • Operating System: Windows 10 Pro 64-bits
  • CPU: Intel® Core™ i5-9400-F @ 2.90GHz (6 CPUs), ~2.9GHz
  • GPU: NVIDIA GeForce GTX 1650 SUPER
  • Citra Version (found in title bar): Citra Nightly 1629
  • Game: Project X Zone 2 Update v1.2 (USA) - 0004000000160C00
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1629 HEAD-1bb2057
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-9400F CPU @ 2.90GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1650 SUPER/PCIe/SSE2
GPU Driver Version                            457.09
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hm, upload a save file (Right click on the game on Citra -> Open Save Data Location, zip the file(s), upload it to like Google Drive, OneDrive, Dropbox etc then link it here) and give steps how to reproduce the issue.

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Here is the save data:

https://drive.google.com/file/d/1jy_iv3nrm671WcrLLBMxS5dzTvJuTyjk/view?usp=sharing

Just start the game, load the save file and start playing. The first battle you engage (being your turn or the enemy´s in case you counter them causes this incident).

I will try the configuration advice and post the results!

Thanks for your time, @tywald!

I just tried the configuration, sadly it ended with the same results.