PSMD Freezing up after credits

Ive been playing the game for about 2 days and it went completely fine, till after the credits it completely froze up like this

System Information

Diagnostic Log

Apparantly the log is to big and i also couldnt upload it to discord, so i uploaded it to discord as a zip, that should be good, right?

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Looks like a corrupted ROM. You’ll need to redump your game. Please refer to our game dumping guides:

Dumping Game Cartridges
Dumping Installed Titles

Make sure your GM9 is up to date and that you have enough free storage space available on your SD-Card to perform the dump

i found what was causing it, it was one of the cheats that corrupted some itemdata apparantly and upon launch it just crashes as it is trying to load said data. or so i am assuming as ive tried with a fresh rom, tried it and it happening again.

meaning a simple deletion of all my data was what it needed ,_,

I could not find any cheats enabled in your log file. Though it’s possible you cheat codes corrupted your save data in the past.