Pushmo Camera support not working

Issue: System camera support in Pushmo.
I have configured yuzu to use my PC’s camera for the 3DS system cameras in the camera settings tab, yet when I try to scan a QR code for the game (Pushmo) the entire QR scan screen is black. Same result when I tried using an image as a source, just a giant black screen for what would have been the camera. This issue might exist in its sequel games crashmo, and stretchmo but I have never played those games so I wouldn’t know.

System Information
Operating System: Windows
CPU: Intel i7
GPU: GeForce RTX 2070
Citra Version: Nightly 1708
Game: Pushmo (NA)
Screenshot of Issue:

Log file:
citra_log.txt (13.1 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Make sure you configured the right camera for your game in Citra’s settings. Some games only use the front camera, others only use the rear camera. Setting the wrong camera for your game would result in a black screen similar to your screenshot.

Emulation>Configuration>System>Camera Tab

Camera to configure:

@SleepingSnake I tried all three and none of them seemed to produce a different result.



just tried on citra mobile (one+6) same result

Alright tried the same thing with crashmo the sequel to this game and once again same result.

Also worth mentioning is the load stage from SD option.
I was able to generate my own level and citra even saved it to the virtual SD card, but loading the QR code I just created didn’t work. Hitting the load from SD button results in the screen attempting to transition to the SD menu but it never does.

Make sure you configured the right camera to use before you launch your game. Changing it whilst you’re running your game doesn’t actually make it apply until you relaunch it.

It seems relaunching the game didn’t solve the issue either.
IIRC the game uses the rear camera to scan QR so I set it to these settings.


Then when I hit ok and reopen the settings menu (without even launching any game) it defaults back to this instead.

Maybe that’s my issue, Citra just defaults back to the front camera instantly after closing the settings menu thus why no matter what I set the camera too it’s always the front-facing one.

Are you sure you’re selecting Ok at the bottom of the settings menu after setting your changes?

Yeah I hit ok and somehow it doesn’t save any of the camera changes. Should I try updating citra manually see if my install is jut bugged or something?

You can’t choose which camera to use, that’s hardcoded into the game, you just choose which one to configure here. It doesn’t switch back, both stay configured even if it shows Front again when you reopen the menu. This is rather inconvenient GUI design, they could as well have used tabs instead.

@SleepingSnake Sorry to keep dragging you into this but unless you got any other ideas on how it might be an error on my end is there a way for me to submit a bug fix request/ticket for the dev team?

I confirm that this problem does happen in Pullblox (EUR version of Pushmo), Fallblox (EUR Crashmo) and Fullblox (EUR Stretchmo). I don’t have a webcam and use a saved image, but the exact same thing happens: there’s only a black area instead of the image. Everything is set right, the preview in the settings is correct, but it’s all black in the game.

I use Citra Nightly 1716.

I don’t think it’s relevant, but here’s my system:

Intel(R) Core™ i7-6700K CPU @ 4.00GHz 4.00 GHz
Windows 10
NVIDIA GeForce GTX 1080

This is actually a big issue for the games, because this prevents the import of user made levels, which is the core of the games IMO, it’s an important feature.