Puyo Puyo Chronicles - Missing shaders on hardware rendering

Issue:
when using hardware rendering, eyebrows are missing from the characters (both in battle and in cutscenes), some shaders behave differently from hardware (for example Ally’s heart glows a lighter pink on 3DS hardware but on citra does not have a glowing effect)

When using software rendering, eyebrows show but there is a significant performance impact. Shaders show as correctly expected though the game is unplayable due to framerate in this rendering mode.

System Information

  • Operating System: Ubuntu 18.04 x64
  • CPU: Intel i7 7700
  • GPU: Nvidia GTX 1050 TI
  • Citra Version (found in title bar): Citra Nightly #963
  • Game: Puyo Puyo Chronicles
  • Screenshot of Issue (include the full Citra window including titlebar):
    Hardware rendering enabled

Hardware rendering disabled

Diagnostic Log
citra_log.txt (22.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

just to be clear, you did try ‘Accurate Multiplication’ and/or ‘Accurate Geometry Shader’ right?

Yes, I tried all variables of the graphics settings, all with the same results.

try citra canary and see anything changes. submit your issue here, be clear about the setting names that you tried, also include these screenshots, log and system specs.

Thank you for your assistance. I’ve tested with Citra Canary and the same results persisted. I’ve logged an issue on the github page you’ve provided.