Question About Speed-Up Function

Issue:
Hello, Earthlings! I have a curiosity about the emulation speed on Citra. When I first downloaded the program a few months ago, I was capable of emulating up to almost 400% of base game speed, and running Camtasia to record gameplay wouldn’t cause the game to slow down. I haven’t changed the computer I’m using since then, but now I can only get up to about 175% of base speed without running Camtasia, and using Citra + Camtasia at the same time causes the speed to fluctuate between 80-95%, which makes for choppy gameplay and audio. Is this because of something I’ve done, or is it the result of a change to Citra? (For reference, I haven’t updated Camtasia in the last few months, so that program hasn’t changed at all.) This issue hasn’t been too pronounced over the last few days, but I’d like to know, if possible, what’s causing the difference in speeds.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-7300HQ
  • GPU: GTX 1050
  • Citra Version (found in title bar): Nightly 1659
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (4.0 KB)

If there’s any additional info you need, please let me know.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Your log is cut off, you probably should reupload a new one.

Core_CPUClockPercentage: 50

Change this back to 100%, underclocking Citra might make things unstable and can lead to crashes.

Renderer_UseResolutionFactor: 6

You should probably dial this back down to 4x or so for 1080p display (large layout). 6x is 1440p.

Okay, I’ll give those a try. Thx

citra_log.txt (4.0 KB)

Here’s another log. I toggled the settings you told me to, but my speed is still not even up to 200%. It’s actually lower now at 135%.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hm, log is still getting cut off for some reason :confused:

Since you mentioned you have a GTX 1050 and since you are on a laptop you need to make sure that in Nvidia Control Panel you have set preferred graphics processor to Nvidia in Manage 3D Settings. Power management mode should be set to Prefer maximum performance. If you also have GeForce Experience installed, turn off Battery Boost.

Okay, so before you posted this reply I changed to Canary, and it’s slightly better during recording. I just now changed the settings you suggested as well, and I’m also attaching the Canary log, so see if that one is getting cut off too.

citra_log.txt (135.4 KB)

System Information for Support

Client Version                                Canary 1903 HEAD-6385727
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1050/PCIe/SSE2
GPU Driver Version                            457.09
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Just to address the bot, cheats are now disabled as well, and it made no noticeable difference.

Render.OpenGL video_core/renderer_opengl/gl_rasterizer_cache.cpp:IntervalHasInvalidPixelFormat:1712: Surface found with invalid pixel format

iirc, this is about Format Reinterpretation. See if using 1x (240p) resolution speeds it up.

You can then try these two builds and see if they make any difference:
https://github.com/citra-emu/citra-canary/releases/tag/canary-1042
https://github.com/citra-emu/citra-canary/releases/tag/canary-1041

Setting the rez to 240 gave me about a 25% speed boost (from 190% up to about 250%). I’ll try the other builds tomorrow and see if they work better.

So I tried both of those versions that you recommended. They both give me better speed, but neither one of them responds to my controller commands. So it speeds up better but I can’t use my controller while playing. I have to play with the keyboard.

Nevermind, I got the controller working properly. It’s still not quite up to 400% speed, but it’s around 275% now pretty consistently. Thanks for your help.

It doesn’t seem to be a regression if you got up to 400% before. Go into Nvidia Control Panel and set Power management mode to Prefer maximum performance in Manage 3D settings. If you also have GeForce Experience installed, turn off Battery Boost.

Battery boost keeps turning itself on, but I’m up to about 375% now. I’d say that’s okay personally. Thanks for the help.

Oh, I just remembered. I found something else bizarre. The emulation speed slows down over time. If I have it at 300% speed it will drop as I play the game. Is that normal? (It resets if I exit the program and reopen it.)

Oh also the 1041 and 1042 versions you linked me to don’t have the “Save State” and “Load State” functions. I just found some utility for those, so those would be good to have if you have another version with the that and the better functionality.

There’s a few other things you can try (on current versions):
turn New 3DS Mode off, there’s some precedent with some games of it decreasing performance (more cores need to be emulated, scheduler overhead, etc.)

I’ll give that a try. Thx