"R" button from 3DS function is sticking and never turning off

Issue:
I boot up a game and it runs like normal, but then when I press the controller button bound to the emulator “R” button functionality, that functionality proceeds to stick and act like that button is being held down continuously, only stopping when I manually hold down the button bound for that and resuming as soon as I release the button. As a result Monster Hunter XX is unplayable.

Since I downloaded the two latest experimental builds of Citra with cheat functionality earlier today I thought it had to do with those. But then I ran the same MHXX game in all four versions (Normal Nightly, Normal Canary, whojan’s build w/ cheats, and Citra Valentin with cheats) and the issue was in every single one even after updating to today’s exact version.

Edit: Just attempted to use a different controller than the Xbox360 controller I was using. With an XboxOne Controller the issue is still present.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i3-6100U @ 2.30GHz, 8.0GB RAM, Intel Graphics 520
  • GPU:
  • Citra Version (found in title bar):
  • Nightly: #1024
  • Canary: #917
  • Citra-Valentin: #708
  • dwhojan’s latest build
    Issue is happening in all versions of Citra.
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):
    I don’t know how to take a proper screenshot, and only a screen recording would capture the issue.

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (29.7 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Remember that there is no support for unofficial builds on this forum, talking about an issue that also happens on them is pointless.

that can happen if you configure your keys while in game, close citra, open again, restore defaults, and configure your keys again, all before launching the game.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I just re-tested it to confirm it’s not a problem with specific builds.

The same R sticking happens in Nightly, Canary, dwhojan, and Valentin.

Something is wrong in the common files shared amongst them, whatever they are. I press the R button once and the emulator never lets go of said button. Pressing the R button again stops the sticking but as soon as I let go it resumes.

Just want to say I was able to reproduce this on the latest Canary with an Xbox360 controller.

1 Like

Yeah, it doesn’t matter what controller I’m using or what else. I configure controls usually outside games, but sometimes ingame. Didn’t make a difference.

Game boots up normally, but as soon as the R button functionality is activated it sticks and doesn’t let go.

I would suggest that you create a GitHub issue, and be sure to include all details and the log.

Can you take a screenshot of your input window? Does the button being mapped being reported as “Axis” ? You probably need to bind on release. Hold down the button before you press to bind it so when you have clicked to bind while you are holding it just let go(release) and it should have bound on release. I don’t remember which axis is correct but I believe it should say + and not -. I believe it’s due to them being pressure sensitive or something.

2 Likes

The input window says R is mapped to “Axis 5-”, which is the ZR button on my Xbox360 Controller and on the XboxOne controller my roommate let me borrow to make sure it wasn’t my controller causing the problem.

I held the button, clicked the button to unbind the “R” functionality, and it bound as soon as I let the button go. It still caused the same problem.

Okay, I just tested it again and it’s a problem with the R button functionality and not what button triggers it.

Any button triggering the R function causes the function to stick and not let go unless you hold the button down, only for it to resume as soon as you let the button go, which is the exact opposite of what should happen.

Okay so now I tried to hold down the R button and it wouldn’t even hold in place anymore, making scrolling through any menu or item pouch in monster hunter impossible.

Aaaaand now I tried to replicate it again and it’s not sticking anymore, even though I updated earlier today and it was causing problems 5min ago.

¯_(ツ)_/¯

I have literally zero idea what is going on.

Well the hint that you showed was “Axis 5-” it should most likely have been ‘Axis 5+’. You can edit in the config file qt-config.ini to change that manually if you can’t seem to do it from the input window.

Well if it’s working it’s working so maybe you don’t have to do anything.

3 Likes

YES THIS WORKED THANKS SO MUCH
IT SHOULD BE AXIS PLUS SIMPLY HOLD BEFORE YOU MAP THE TRIGGER THEN RELEASE IT AND IT WILL STOP STICKING THE TRIGGER. this fixed my problem

1 Like

Thank you your a life saver!! This should be the top thing on google when you search this issue!