Random crashes on different games

Issue:
The games run perfectly but at random points, Citra will freeze and close, without showing any error popup or anything. The 2 games I have been playing the most recently, which both crashed at different points and time intervals, were Persona Q and Mario & Luigi Dream Team Bros.

It started happening several weeks ago, but it’s random, I’ve been able to play them for over 2 hours straight without running into any problems, so I have no idea what’s going on. This time I thought I’d ask about it and remembered to copy the log.

System Information

  • Operating System: Windows 10
  • CPU: Intel core i5 8250U
  • GPU: GeForce MX150
  • Citra Version (found in title bar): Citra Nightly 1272
  • Game: Persona Q and Mario & Luigi Dream Team Bros.
  • Screenshot of Issue (include the full Citra window including titlebar): no error message shows up

Diagnostic Log
citra_log.txt (31.1 KB)

System Information for Support

Client Version                                Nightly 1272 HEAD-186ffc2
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce MX150/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Tried Enabling Accurate Multiplication, because why not, and the problem persists.

I managed to play some more, saving more frequently (still lost some progress a couple of times but w/e), except just now it crashed within 10 minutes of playing.

Here’s the new log:
citra_log (2).txt (29.3 KB)

System Information for Support

Client Version                                Nightly 1272 HEAD-186ffc2
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce MX150/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try playing with ‘Enable Hardware Shader’ disabled.

I went with your suggestion, emulation slowed down quite a bit on some parts of the game, and alas, another crash after about a little over an hour.

citra_log (3).txt (59.1 KB)

System Information for Support

Client Version                                Nightly 1272 HEAD-186ffc2
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce MX150/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Did you change anything on your computer since this random crashes started happening? do you remember on which citra build (e.g: nightly - 1250) this issue started happening?

Only changes were updates to my graphics driver, and to citra when prompted by the maintenance tool. I can’t be sure in which version it started, I didn’t pay too much attention to it, I just kept hoping the next update would fix it.

I thought the log would have some clues about it but it seems like it isn’t helping (I couldn’t understand the thing on my own).
I’ll backup my saves and try a clean install, maybe remove it from my external drive, and make an update here later.

Thank you for trying to help