Retrolink GameCube Controller causing crashes

Issue:
I have about 20 hours in Persona Q now, but the game is no longer launching, and just crashes Citra now.

EDIT: The game only refuses to launch when I have my USB GameCube controller plugged in, which up until now I have been using to play the game.

System Information

  • Operating System: Windows 10 64-bit
  • CPU: AMD FX-6300
  • GPU: Nvidia GeForce GTX 760
  • Citra Version (found in title bar): Nightly #812
  • Game: Persona Q: Shadow of the Labyrinth

Diagnostic Log
citra_log.txt (1.1 KB)

I found some issues in that log that need resolving:

I found some issues in that log that need resolving:

If anyone is wondering, it’s a Retrolink USB GameCube controller that connects directly to my PC. Trying to modify the controls also causes Citra to crash, so I’m fairly certain that’s the real issue.

This happen to me too. On a generic usb controller only on Windows 10, on 7 the emulator don’t crash. Try to run Citra on Windows 7 if you can and see if the emulator crash while mapping the buttons with your controller.

I don’t have access to an actual PC with Windows 7, but just for the hell of it I tried running it in compatibility mode for Windows 7 and 8. Also, just to clarify for anyone else, this is a pretty new issue for me, since I’d been using the controller for about 20 hours worth of Persona Q.

Since this issue seems kind of new, is there any chance that it’s tied to a more recent update?

As far as I know, GameCube controller adapters can be kinda weird with these things. I’ve seen instances of modern games crashing if an adapter is plugged in. I’d be curious to see if this doesn’t happen on older versions of Citra though.

I’ve actually been having internet issues lately so I was only able to download a few builds, however I’ve found out that version 794 works while 798 does not, so I think that if anything there’s a change that happened somewhere in between there. I’ve also updated to the latest live version, but that doesn’t work. So to clarify, the problem is solved but I still don’t know what caused it.