Rhythm Heaven Megamix (Static at start, music is off timing)

Issue:
When I start a minigame, loud static plays followed by the intro music. After the tutorial, a bit of the intro music plays followed by the main minigame music which is off timing. What do I do?

System Information

  • Operating System: Windows 11
  • CPU: AMD Ryzen 5 3600 6-Core Processor
  • GPU: AMD Radeon RX 5600 XT
  • Citra Version (found in title bar): Nightly 1988
  • Game: Rhythm Heaven Megamix

Diagnostic Log
citra_log.txt (26.5 KB)

System Information for Support

Client Version                               Nightly 1988  HEAD-8f8c542
Operating System                             Windows 11 Version 22H2 (Build 22621.2134)
CPU                                          AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            AMD Radeon RX 5600 XT
GPU Driver Version                           22.20.27.09.230424
CPU JIT                                      [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

This driver is out of date. Please update to the latest available: https://www.amd.com/en/support/graphics/amd-radeon-5600-series/amd-radeon-rx-5600-series/amd-radeon-rx-5600-xt

Additionally, go to Emulation>Configure>Graphics>Advanced Tab, and disable V-Sync.

Do note that this game has audio emulation issues to begin with, so you likely cannot get it to run completely perfectly.

Did the changes, but seemed to make no difference

Have you found any solutions yet? been digging the internet for the solution
I’m also on windows 11 btw, thanks

Can you try the latest canary? It should fix some issues we have with the Windows 11 AAC decoder (by using a different one instead)

Yeah, the audio is in sync now. Static is also gone. Thank you!

1 Like