ROG Ally - Windows Security update (KB5034123) causing crash on startup

I’ve run into a Windows Update issue that causes Citra to crash on startup on the ROG Ally.

A link to my original reply:

Last week I uninstalled Security Update (KB5034123) and Citra worked fine. But an update from this week reinstalled it behind a different name/code: "Update for Microsoft Windows (KB5034204)”

The Citra crash on startup seems to be a persistent issue connected to “Windows Security update (KB5034123).” I’ve run into this with every update since Citra Nightly 2086. I even tested the reinstall/uninstall of “Windows Security update (KB5034123)" with other versions to see if it was the issue.

Citra has worked flawlessly after uninstall every time.

The problem now is that I can’t update Windows… Running in compatibility mode will juke the issue, but it’s not a permanent fix. Plus, it causes too many other quirks that make Citra unstable in the meantime.

I don’t know enough about programming to get much further than this, but I thought if I identified the specific conflict MAYBE there’s a chance it could be fixed? I just wanted to bring it to someone’s attention who knows more than me.

System Information

  • Operating System: Windows 11
  • CPU/GPU: AMD Ryzen Z1 Extreme
  • Citra Version (found in title bar): Citra Nightly 2091 - and other versions going back to 2086
  • Game: n/a

No log file to upload, as this is a program loading error.

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

It’s probably due to “opengl, opencl, and vulkan compatibility pack” that was included is a recent windows update that breaks some vulkan appliances mainly emulators.

To fix it go into windows settings. Apps. Look for something called “opengl, opencl, and vulkan compatibility pack”. if you have it uninstall it

1 Like

I am having the exact same issue on my Asus Rog Ally. This is so annoying, I cant find a fix.

Love you, this fixed my issue.

Issue solved for me too. Thank you!

I’m still curious why removing the security update would allow the “opengl, opencl, and vulkan compatibility pack” to function properly. But a fix is a fix!

Thanks again!

Hello, I have resolved this issue by updating the graphics drivers to AMD Ryzen 7 from AMD directly instead of using Asus’ provided update. Following this guide allowed me to open Citra and run games again after. I am running Canary build.