RollerCoaster Tycoon 3 Complete Edition FPS drops when save a game

Hi! I’m trying to play RollerCoaster Tycoon 3 Complete Edition on Yuzu Emulator but the fps goes to 0 when i try to save the game in campaign mode, then nothing happens, it just get stuck on “saving the game” screen.

I’ve tried it on my laptop and on Yuzu for Android, it happens in both devices.

Does anyone knows any troubleshoot?

I’m using the latest yuzu version (1640). Here’s the log:

yuzu_log.txt (61.5 KB)

System Information for Support

Client Version                               yuzu 1640
Operating System                             Windows 11 Version 22H2 (Build 22621.2715)
CPU                                          12th Gen Intel(R) Core(TM) i5-12450H | AVX2 | FMA
Graphics API                                 Vulkan 1.3.260
Graphics Renderer                            NVIDIA GeForce RTX 3050 Laptop GPU
GPU Driver Version                           NVIDIA 545.92.0.0
Host RAM                                     31.71 GiB
Host Swap                                    11.50 GiB
CPU Accuracy                                 Paranoid
GPU Accuracy                                 High

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Getting Started follow guide to properly dump your console files. If it still doesn’t work just stick to playing it on your console or buy it when it’s on sale on steam. Save you emulating it at all.