Rune Factory 4 Font Problem [Solved]

Issue:
Hi just recently I have updated the Citra Nightly to #817 from #811 or something. When I played Rune Factory 4, the font type changed completely. The problem may seem trivial but the characters are too small and uncomfortable to read, is there any help to that?

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5 (7th Gen) 7200U / 2.5 GHz
  • GPU: Intel HD Graphics 620
  • Citra Version (found in title bar): #817
  • Game: Rune Factory 4
  • Screenshot of Issue (include the full Citra window including titlebar):

    vs original font:
    runefactory4-date

Diagnostic Log

citra_log.txt (4.8 KB)

I found some issues in that log that need resolving:

This issue is also present in Super Smash Bros. loading screens too, so I think it’s not just Rune Factory exclusive.

Try using the older version for now until a fix is made is all I can say.

[ 34.605177] Service.FS core/file_sys/archive_ncch.cpp:OpenFile:123: Shared Font file missing. Loading open source replacement from memory

Not really an issue. OP is using open source fonts which may not also be accurate.

@luic You were very likely using Citra in portable mode somehow. Ensure you have moved the user directory to the default location on Windows. If there is a user folder in your previous build, it should be moved to the new location. See Migrate Your Savefile.

I have double checked the locations of the Citra and it is located in Local Appdata and Roaming resp. I have also dumped the shared font.bin into the sysdata folder. I am not quite sure what means portable mode though…

Just to make sure that system archives are in the right place, right click on any game on your game list on citra, click to open save data location. it will be a directory similar to this:
C:\Users\username\AppData\Roaming\Citra\sdmc\Nintendo 3DS\00000000000000000000000000000000\00000000000000000000000000000000\title\00040000\000XXXXX\data\0000000X

just go back from this folder structure to Roaming\Citra and see if the sysdata folder contains the shared_font.bin file.

It should only be in C:/Users/[your-user-name]/AppData/Roaming/Citra/ not in Local. That is where Citra is installed to. You don’t want to put the system files there.See the dumping system archives guide on what to put it.

FYI shared-font.bin has been deprecated though it could still work in Citra. Previously it would be in sysdata folder. It is recommended to redump using the guide. The shared fonts are now part of the shared data archives and in a different format.

Thanks a lot. Problem is solved by redumping the whole citra system archives – I am guessing the shared font.bin cannot work anymore in the newer versions of Citra or it can’t detect the file, or maybe I am using the old system archives.

1 Like

Can anyone please share a link to download the older version so I can use the older version of citra to play. I automatically download the updates when I open the app

You can find older nightly and canary builds here and here. remember that they are unsupported.

1 Like

sorry but i dont understand how to dump system files like those are mentioned, is there a alternative way to fix this font issue? trying both new and older version of nightly citra but same result (here’s an example of how the font aint be read)