Ryzen 5 2400G being unable to run any game

Issue: I really dont know why, but Citra isn’t running in my computer. I mean, yes, it runs; but the FPS for all games that actually open (Pokémon X now crashes when i try) cant go past than 5. It’s specially strange because i saw many videos about the same rig i use being able to use it without problem, and even i played Pokémon X without major problems before. I tried to reinstall it, but no use.

System Information

  • Operating System: Windows 10
  • CPU: Ryzen 5 2400G
  • GPU: APU Vega 11
  • Citra Version (found in title bar): 1694
  • Game: Pokémon X, Pokémon Omega Ruby, Pokémon Sun and Inazuma Eleven Go: Chrono Stone
  • Screenshot of Issue (include the full Citra window including titlebar): Imgur: The magic of the Internet (Velocidade = Speed)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (27.4 KB)

System Information for Support

Client Version                                Nightly 1694 HEAD-e6c479f
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2400G with Radeon Vega Graphics    
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) RX Vega 11 Graphics
GPU Driver Version                            20.11.2 27.20.14501.18003
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • LLE Audio is designed for debugging purposes. Using this option will slow down your game. Try changing to HLE audio.

Well, if you had disabled Shader JIT as well, you couldn’t possibly have selected worse options for performance xD

Please go to File>Open Citra Folder, then delete the config folder here and restart Citra. This should reset all of Citra settings to the default (which is usually best for performance). There is one other thing you could do that might improve performance:

Then go to Emulation>Configuration>Graphics>Advanced Tab and disable Hardware Shaders (this sometimes improves performance for AMD GPU users). Though this setting is a bit hit or miss and can differ per game.