Saving in Pokémon Games Error

Saving in Pokémon Games Error:
Everytime I try to save a pokémon game, it appears a new window with this message: " A fatal error ocurred. Check the log for details. Continuing emulation may result in crashes and bugs". If I click in continue, the saving never ends. This happens with all my pokémon games, but I think that the others that haven’t in-game saving would have this error too. Could you guys please help?? I’m really stuck here… (Obs.: error just present in in-game savings , not in the state ones).

System Information

  • Operating System: Windows 10, 64 bits
  • CPU: i3-4130
  • GPU: None, but the motherboard is ASRock H81M-HG4
  • Citra Version (found in title bar): Citra Nightly 1695
  • Game: Every single one of them.
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (15.3 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1695   HEAD-c2d36cd
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i3-4130 CPU @ 3.40GHz
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 4400
GPU Driver Version                           20.19.15.5070
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

I don’t think the problem has anything to do with gpu drivers, since it worked normaly before. It’s worth mentioning that this error started to happen after my computer was fixed, and the citra archives were normally put on the new windows, and the citra worked great. Then, I got the old saving archives from my drive and put in the saving folder, replacing the files from when I tested to see if the games still worked for the new old ones. Them, coming back to my old saving states, in-game saves have that error.

Based on what you have said here and the mention of you using save states in your log file, have you transferred save states from one computer to another? Your wording is a little hard to understand.

Yes, kinda… I had to reset my computer and bring all of the old files to the new windows.
Sorry about my wording, i’m a Brazilian trying to comunicate in english…

Save states cannot be transferred between different Citra installations. Loading them will start to break things. Only actual in-game save files can be transferred this way.

My Citra is run by boot, not installed, and the citra itself didn’t changed, as I just copy-paste the citra to the new computer, and it’s the same with state files
So, I don’t know if the citra can be considered “different”, since I didn’t download it again
But thanks for the information

Something as small as a change in the file path is enough to break things. Not to mention hardware differences. Save states save everything about the emulation state. So that includes the status of the VFS system. If your username, drive name and all other folders in between aren’t exactly accurate to the old system, any time Citra requires access to the VFS after loading the save state will result in Citra attempting to write to a folder/file that doesn’t exist (since the pathing isn’t correct). Which will break things.

1 Like

Ok, thanks for telling me that
At least I still can play with the off-game (states) saving
Really useful, thanks!

1 Like