Screen Goes Black then to Not Responsive with Pokemon Alpha Sapphire, Ultra Sun&Moon

Issue:
Me and a Friend were attempting to coordinate doing a nuzlocke but upon trying to load the decrypted ROM of Alpha Sapphire Citra immediately widens to a black screen and then to Not Responsive/Crashes if I try to interact at all until I’m forced to kill it. When I’ve checked the log file it shows this
citra_log.txt (12.7 KB)

System Information

  • Operating System: WINDOWS 10 PRO
  • CPU: i7-10700k CPU @ 3.80GHz, 3792 Mhz, 8 cores
  • GPU: NVIDIA GeForce GTX 1660 Ti
  • Citra Version (found in title bar):
  • Game: Pokemon Alpha Sapphire for the error and screenshot, Also occurring with Ultra Sun&Moon.
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

I did as reccommended but this is the log file I have after being forced to kill the tasken when it becomes unresponsive and then I did not open Citra and uploaded the log file.

citra_log.txt (16.5 KB)

System Information for Support

Client Version                               Canary 2256   HEAD-6e5db49
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2
GPU Driver Version                           516.94
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • You have mods installed. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

I deleted whatever was in the mods folder. Still crashed the same way after attempting to open game

citra_log.txt (15.0 KB)

System Information for Support

Client Version                               Canary 2256   HEAD-6e5db49
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2
GPU Driver Version                           516.94
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Let’s try out a portable Citra build to rule out any issues with your Citra installation or appdata:

Go to Download Citra - Citra and select Manual download. Then under Nightly Build, click on your operating system’s icon to the right of the latest build available to download the build.
Extract it (.7z can be extracted using Winrar or 7zip) and put it where ever you wish. Inside the extracted nightly-mingw folder, create a folder called user. This Citra should now store all of its config, save files and such inside of this user folder.
Check to make sure that this user folder is in the same folder that contains citra-qt(.exe)
Now run the citra-qt executable found inside of the mingw folder and run your game.

I only just saw this reply now, but feel I should go ahead an advise that after trying so many things like clean installing my graphic drivers, anything else i found recommended by others for similar problems, and etc. Me and my friend I was doing this for couldn’t find anything resolving it, but he was running the games just fine with no issue.

I will test the up to date build for it, but I can confirm when I got the build of Citra he is currently using, which meant getting Build 1903 of Canary with the portable build folder you described, it is successfully running the games with no issue. I’m not sure if that rules out anything, but I will test installing the up to date build and see if anything is different.