Screen Randomly Freezes, but FPS remains at 30 or 60 and the sound still plays

Issue:
Citra will run games perfectly, at fixed 30 FPS. However, at a certain point in the games I’ve tested (Bowser’s Inside Story, Ocarina of Time 3D, Paper Jam, Dream Team, etc.) the screen will permanently freeze, although the sound will still play and the FPS will remain maxed out.

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-4440 CPU @ 3.10GHz
  • GPU: Intel® HD Graphics 4600
  • Citra Version (found in title bar): Citra Nightly 1598
  • Game: Mario and Luigi: Bowser’s Inside Story + Bowser Jr’s Journey
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log

citra_log.txt (26.6 KB)

1 Like

System Information for Support

Client Version                                Nightly 1598 HEAD-b4ec50b
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4600
GPU Driver Version                            20.19.15.5126

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Intel HD 4600 is a problematic GPU, you can try turn off Hardware Shader and see if that fixes it.

Since you have an i5-4440 which is a desktop CPU, do you know if you have a graphics card in your computer or do you really only have integrated graphics?

2 Likes

Hello! Tried that before. When I turn it off, the games will run at mostly 2 FPS. About the graphics card, I’m not 100% sure, but I think it only has integrated graphics.

1 Like

Are you sure you are turning off Shader and not Renderer ? Turning off Renderer will cause you to get around 2 fps :stuck_out_tongue:

You can check if you have more than integrated graphics by going to the Device Manager and check under Display adapters.

2 Likes

Ok, I was straight up dumb.Sorry! Apparently, it solved the issue. But I’m aware of the “3D models will not render properly without Accurate Multiplication” issue. Will that affect my game? I checked and, sure enough, my PC only has integrated graphics.

1 Like

Since HD 4600 has issues, you might need to also turn off Disk Shader Cache in addition to Accurate Multiplication.

If you buy an Nvidia graphics card in the near future these problems should go away and also boost performance significantly.

2 Likes

Thank you! Actually, it went much better than I thought. The 3D models flashes, but it’s almost unnoticeable. Thank you for everything!

2 Likes