Screen rotates when pressing l and r on pro controller

So i was playing OoT and when i press L and R the screen rotates for some reason (using pro controller)

System Information

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Strange it looks normal in the screenshot but its upside down when i play it

The topic’s title appears to indicate that pressing the L or R buttons brings up “citra menus” of some kind, yet the description of the topic indicates that your Citra screen is “rotating”. Since these appear to be conflicting reports, could you perhaps rephrase/elaborate some more on the issue?

When i press L and R at the same time and move the left joystick, the camera rotates, when i press R the archive button is selected and since im playing the game, when i press A (enter on pro controller) It opens, so i have stop and get out of fullscreen to get out of the archive menu thing

(The archive button is blue because i press R)
I think its because my buttons are same as the keyboard “keys”

I also tried to map the inputs but it never worked since my pc doesnt have bluetooth but i think steam can do that, since i connected the controller with steam, never tried changing the buttons tho

From what you describe your “R” button seems to be acting like the “Alt” key, and your “L” key seems to be acting like the “Ctrl” key.
These issues should go away if you stop using the controller as a keyboard and just configure it as a controller on Citra. That can be done via Steam or DS4Windows (by Ryochan7), and then you can map it via Configure > Controls.
If that’s not possible, you may try launching Citra through Steam and see if Steam will automatically switch to controller mode (as you mentioned you’re using it to map your controller to keyboard inputs).

For an explanation on your issues:
On computers with Intel graphics, a standard hotkey for rotating the display is “Ctrl+Alt+Arrow Key”, which you seem to hit when you do “L+R+left joystick”. You should be able to disable these at the Intel control panel, by disabling system hotkeys.
For your problem with selecting the “File” menu, that’s a default behavior in windows, not much we can do to change it.

I think i changed my inputs on citra because a was b and b was a? Anyways ill try

I found the menu to change the buttons but i dont know how to map it so that problem wont happen again…

Oh wait nvm it worked tsymm