Screenshot Hotkey stopped working

Enter a description of your issue here, in full detail.
I updated Citra Nightly from 1800 to 1861 yesterday. Even though this is quite a big step, I never expected I would face any trouble because most experiences I’ve ever got with Citra are all good.
But I eventually came across a problem. It is not that critical but still kinda sticky.

The main problem is about the hotkey feature, especially snapshot.
After updating, the snapshot hotkey doesn’t trigger making a snapshot at all.
Whenever I press Ctrl+P (which is default setting for this), It doesn’t save any screenshot file in the folder I specified and even doesn’t try to stop emulating. (it should’ve stopped briefly if the snapshot had been taken correctly)
Additionally, even the log file doesn’t detect there was an input for making snapshot in spite of my actual action.

Initially I thought it is a problem related to the hotkey combo for a while, so I changed snapshot hotkey combo to another one (like num0 or F12), where nothing got resolved.

I tried some more method to retrieve this.
I used both L-Ctrl and R-Ctrl, restarted whole PC, re-plugged my keyboard, and ran Citra with administration authority but nothing among these was effective (at least the last one worked for the first 3 mins tho)
At this moment, the only way to take snap for sure is to click ‘Capture Screenshot’ button in the ‘Tools’ tap.

If there is any solution for this problem, It will be appreciated.

System Information

  • Operating System: WIN10 Pro 64bit
  • CPU: AMD Ryzen 5 1600
  • GPU: NVIDIA GeForce GTX 1060 6GB
  • Citra Version (found in title bar): Nightly 1861
  • Game: Inazuma Eleven Go Galaxy - Big Bang (JPN)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

I’ve just tested it myself. And I can confirm I can reproduce this issue. Curiously, if I open the Emulation>Configure menu, and press Ok to close it immediately after, the hotkey works again for a bit of time (if I deselect Citra as a program, it sometimes stops working again). Thanks for reporting it, I’ll forward it to the devs.

1 Like

It’s a mercy that this is not only my case!
This issue is too tricky so I want it fixed as soon as possible for everyone.

Thank you so much SS! Have a nice day :grin: