SD Gundam G Generation Genesis | Infinite "saving..." screen

yuzu_log.txt (910.9 KB)
As the title says, whenever I save, it stays on that screen forever. If I close and go back in, there is a save file but it is a corrupted save file and cannot load that file to continue. Always have to start a new game every time I play the game.

There’s a missing services required to make it work, I’ve notified our developers about it.
Can you try enabling auto-stub in Emulation > Configure > General > Debug? It will only last for that session, so remember to re-enable it in any next try.

Thanks for the reply, but it looks like auto-stub does not solve the problem. It still stays on the “saving…” screen.

I am also having the Exact same issue using Yuzu 601. I have redumped the game a couple of times and get the same result.
Anything else I can try to get it to work?
Log deleted.

Been having the same problem.

Did all the previously mentioned troubleshooting with the latest version(604, plus updating video drivers), however, the issue persists. I can play the game without a hassle, however, saving is impossible due to that. You attempt to save and the game feezes in place with the “Saving…” screen, music playing and FPS dropping to zero, leaving you no other option than stopping the emulation. Here is the log, if that helps in any shape or form.

Further input is greatly appreciated!

yuzu_log.txt (792.5 KB)

A fix is in Early Access for testing, after a couple of days it will be in Mainline, and this should be fixed for good.

1 Like

Thank you and the developers for the hard work! :slight_smile: I will reply the result when the fix is released publicly.

1 Like

If I’m not wrong, it should be in today’s mainline.

Just tried it, but it doesn’t seem to be fixed. Tried auto-stub as well, but didn’t solve it. Maybe it’s not today’s mainline, or it’s just my thing. I’ll leave the log just in case.

yuzu_log.txt (3.3 MB)

Yeah, seems like it didn’t manage to get into this build version.

Still like this , yuzu 663
Can someone menage to resolve the issue ?

Thanks, reported it to the devs. Seems like the initial fix was not enough.

Evening. Any ETA, update on the matter?

Yuzu 670, still happening.

Our developer working on the file system fixes is aware of the issue. Will take some time to finish that work and publish it.

Yuzu EA1855, still happening.
can’t save the game, so I have to restart the new game every day. I hope this problem is solved soon because it is a fatal error.

actually you can save, but still stuck on the save screen…

i made a little experience, so i create new save data in ryujinx, moved them to yuzu, use cheat to see if i can save it, and… voila… saved… but only data.bin at data00 folder that had been rewrite, rest of them just same… (which is when you wanna load, save data screen showed not the last time your data saved, but still load your last saved data… funny right ? :sweat_smile: i think this one makes a brand-new-start save data on yuzu gonna corrupted)

for now, i play SD Gundam Genesis in yuzu just for cheat purpose :rofl:

waiting for dev team to fix it… thank you so much

Same problem here, infinite saving screen while music plays in background. Restart the game and the save file shown corrupted.

This is off-topic, but I’m curious.
Can you point me to where to get the cheat file please? I also want to get the genesis cheat file and apply it.

@BlueWindy - hear you go, but I don’t know if they are for this game.

Unfortunately I couldn’t find any cheats for this game in the link you sent me. However, thank you for your willingness to help me :slight_smile:

1 Like