Secure1 KeyX Missing. How can I fix?

Issue:
The game black screens when I try to open it. The music plays in the background but I can’t see anything. If I try to interact with Citra when the game is running, it will say “not responding”. When I look in the Log Console it shows an error code saying that “secure1 keyx missing”.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (5.0 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The log file is incomplete. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder (Citra>Open Citra Folder if on MacOS) and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch and close citra if it doesn’t do so by itself. Do not restart citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.

citra_log.txt (28.7 KB)

System Information for Support

Client Version                                Nightly 1715 HEAD-afed495
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2
GPU Driver Version                            471.11
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try disabling your texture filter and then restart Citra.

citra_log.txt (28.7 KB)

Same issue :frowning:

System Information for Support

Client Version                                Nightly 1715 HEAD-afed495
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2
GPU Driver Version                            471.11
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Has the game ever run at all up until this point? Or were you never able to open it properly yet?

It would run perfectly every time I’d reinstall Citra and had run it for the first time (I’ve tried installing both with the install Wizard and manually to see if I’d get different results). But after that this issue keeps occurring when I try to open it again

That’s odd. Try disabling the Disk Shader Cache in Emulation>Configuration>Graphics>Advanced Tab.

citra_log.txt (32.8 KB)

Still not responding

System Information for Support

Client Version                                Nightly 1715 HEAD-afed495
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2
GPU Driver Version                            471.11
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I discovered that if I run Citra as an Administrator, the issue doesn’t happen and it runs

Hmmm, never heard of that being an issue before. Might be a permission conflict then.

citra_log.txt (34.5 KB)

System Information for Support

Client Version                               Nightly 1778   HEAD-a51b1cd
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 2600 Six-Core Processor             | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Radeon RX 580 Series
GPU Driver Version                           22.7.1.220725
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                2
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Use the latest Citra Canary for now. AMD’s new driver requires a workaround that’s only available in Canary.

1 Like

My new AMD Radeon X 6600 wouldn’t work at all with Citra until I tried the Canary version as you suggested. Thank you

citra_log.txt.old.txt (29.9 KB)