Sega 3D Japanese Collection 1-3 doesn't boot any games

#1

Issue:
The introduction video when starting the game and entering the main menu works perfectly fine but whenever you select ANY game from the selection list it restarts the entire 3DS emulator/game (showing japanese warning screen followed by SEGA screen, etc…)

System Information

  • Operating System: Windows 10 Home Edition 64 bit
  • CPU:
  • GPU: AMD A10-7800 Radeon R7
  • Citra Version (found in title bar): Git #851
  • Game: Sega 3D Fukkoku Archives 1-3
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

According to the compatibility page, this is the current state of this game.

this issue is still open on the issue tracker:

i know that the Sega 3D Classics Collection isn’t exactly the entire collection, but its the western release of Sega 3D Fukkoku Archives 2 which falls under this collection.

#4

yeah i know the 2nd collection is the one we got western side, so has anyone know why it happens yet or no idea? is it the built-in emulator sega uses for these games?

#5

it requires testing and debugging to know exactly the reasons, but many other sega 3D releases (e.g: Sonic, Super Hang-on, Shinobi, streets of rage) works, and they are emulated.

maybe some updates did fix some parts of if since this issue was reported, you can also submit your testing results on that issue thread, just include your system specs, log, and how to problem occurs.

btw, test different settings before you submit, like ‘Enable CPU JIT’ enable/disabled, ‘Enable Shader JIT’ enable/disabled and ‘Enable Hardware Renderer’ enable/disabled before launching the game.

#6

Alright, thank you! will try it out once i get the chance later on and will let you if it fixed it or not