Sending and Receiving Animal Crossing New Leaf Save Data

Issue:
My friends and I want to make a town in Animal Crossing New Leaf and share it. Basically, one of us messes around in it for a day, then gives the save data to the next person to see the changes the others made and also make changes, pass it to the next person, etc. We did it in the past with the Gamecube version by just sending over Dolphin’s memory card file, and we want to give New Leaf a whirl this time.

I sent the contents in the 00000001 folder (the one that opens when right clicking on the game in Citra and hitting Open Save Data Location) to my friend and he supposedly loaded the Test town I made successfully (I only saved right after planting the tree at the very beginning of the game). In that zip I sent to him, there were friend1.dat, garden_plus.dat, and updated.dat. He booted up the town, rearranged the inventory to see if I would get the right data, then sent me back a zip of his 00000001 folder. However, in his folder, there was exhibition.dat alongside the other three. Booting up the game with those four files in my 00000001 folder only gave me the “New Save File” option on the menu with no “Continue” to load his save data. To make sure it wasn’t just his files being messed up, I put the files I sent to him back into my 00000001 folder in order to load my Test town (which should’ve worked for sure if it worked for him), but even then I still didn’t get a Continue.
At some points throughout this whole process, I went into the folders 00000001 is contained in and deleted some files like “identity” and “00000001metadata,” that I guessed were getting in the way of reading foreign save files or something, but that was only after I couldn’t get a Continue. As a result, I don’t think those files being missing are the issue (but I’m not sure if deleting them will cause more issues down the line).

Given my friend’s success, it’s definitely possible to transfer save data just fine, but I have no idea what I’m doing wrong. Any ideas?

System Information

  • Operating System: Windows 10 Home 64-bit
  • CPU: Intel Core i7-6700K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
  • GPU: NVIDIA GeForce GTX 1070
  • Citra Version: cITRA nIGHTLY #792
  • Game: Animal Crossing New Leaf (Welcome Amiibo)
  • Screenshot of Issue:

Log (of my latest attempt of trying to load my Test town):
citra_log.txt (17.8 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

some games also use the sd card to save content, ACNL probably does it too.
if you look at the directory structure when you open your save folder location:
C:\Users\%username%\AppData\Roaming\Citra\sdmc\Nintendo 3DS\00000000000000000000000000000000\00000000000000000000000000000000\title\00040000\title id here\data\00000001

where ‘title id here’ should be your game title id, which is always the last four digits 00XXX00
(something like that)

if you go back to:
C:\Users\%username%\AppData\Roaming\Citra\sdmc\Nintendo 3DS\00000000000000000000000000000000\00000000000000000000000000000000\extdata\00000000

this is your extdata (sd card stuff), your title id (not the correct term but whatever) is in this folder but with the nomenclature 0000XXXX

just look for the folder with the same name, if you want to be sure, just look at:
https://citra-emu.org/game/

your game id is based on your region, ACNL europe for instance: 0004000000198F00
where 0004000000XXXX00 is the id you are looking for.

Alright, I’m not too sure WHAT happened, but I got it working. Based on what bio3c said, I peeped the extdata folder and couldn’t find anything relating to New Leaf saves or anything in it, so I just assumed I had to make a new town so it could create the folder for the save data. So I made a new town (Test 2), saved, checked extdata, and nothing changed.

So I decided to see if anything changed in wherever “Open Save Data Location” took me and it opened 00000001…but there was another 00000001 folder in there. I replaced the files inside the deeper 00000001 folder with the ones my friend sent back to me (of Test)…but the game still loaded Test 2. I replaced the files in the OUTER 00000001 folder…and it loaded the first Test town complete with the inventory changes my friend made!

So basically, I think I messed up by deleting the .dat files in the real 00000001, pasting the 00000001 folder my friend gave me into the real 00000001 folder, then falsely assuming the second 00000001 folder I created was the one the game was using because it was the one with the .dat files in them. I deleted the fake 00000001 folder to make sure and, sure enough, my friend’s save was still intact when I booted the game again.

Wow, what a thrilling mystery with a satisfying solution, huh? But for real, on one hand it was a pretty stupid mistake I made (and then kept making) in hindsight. But on the other hand, bio3c’s reply spurred me to find the solution, so thanks!

2 Likes