Shader Glitches, No Idea What's Going On

Issue:
Enter a description of your issue here, in full detail.
There’s shader glitches occurring, and its killing my fps as a result. I have no idea what’s going on, as it citra was working fine before.

System Information

  • Operating System: Dell Inspiron 15.
  • CPU: Intel Core I7-7500u
  • GPU: Radeon R7 M445 (High power), Intel HD Graphics 620 (Low Power)
  • Citra Version (found in title bar): Canary 1627
  • Game: Fire Emblem Fates, Fire Emblem SOV(upload://6r72Y1xuzo7YTInUB9Dc37Hyh5C.txt) (41.0 KB)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
[citra_log.txt|attachment]
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1627 HEAD-4a03207
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon (TM) R7 M445
OpenGL Version                                3.3.1
GPU Driver Version                            23.20.768.12
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Download and install Adrenalin 2020 Edition 20.3.1 drivers from: https://www.amd.com/en/support/graphics/amd-radeon-r7-series/amd-radeon-r7-400-series/amd-radeon-r7-m445

You should pick “clean install” in the installer so you get a fresh install.

I’ve installed it and ran it, yet I still experience slowdowns and shader glitches. Is there anything I have to do in the settings of the Adrenalin menu?

Upload a new log. You could try running the game on the Intel HD GPU instead(probably need to update another set of drivers for it), by changing Switchable Graphics in Radeon Settings:
https://www.amd.com/en/support/kb/faq/dh-017
iirc, “High Performance” is AMD GPU and “Power Saving” would be Intel GPU.

citra_log.txt (62.9 KB)

Works with Intel GPU, but its still pitifully slow with Radeon. holds 30 fps at 60% speed for some reason.

System Information for Support

Client Version                                Canary 1627 HEAD-4a03207
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon R7 M440
OpenGL Version                                3.3.1
GPU Driver Version                            20.3.1 26.20.15029.15007
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Yeah Radeon is slow for OpenGL on Windows, you would pretty much need to dual boot Linux(e.g Ubuntu) to get more performance because there are better drivers there, open source Mesa for example.

Too bad this is a laptop, if you had a desktop you could change the graphics card(to Nvidia) very easily.

Damn, all right, thanks. Looks like I’m gonna have to use Intel :confused: