Shadows not displaying correctly

#1

I’m currently trying to run Dragon Quest Monsters: Terry’s Wonderland 3D on Citra (Nightly #977), I’m using a Mac so the newer builds weren’t working on my OS.

Whenever I try to play the game, the shadows end up displaying incorrectly. Instead of being under the characters like they should be, they’re displaying off to the side, much smaller than they should be. I can’t seem to figure out the issue. I tried using an older version, which did work, but unfortunately it made the game stutter a ton and I’m kind of at a loss.

Here’s the log:
citra_log.txt (20.6 KB)

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

System Information for Support

Client Version                                Nightly #977 HEAD-687e3e7
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               NVIDIA GeForce GT 750M OpenGL Engine
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
Enable Vsync                                  null
LLE Audio Emulation Enabled                   null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#4

Can you provide a screenshot how it looks like?

#6

Does enabling Accurate Multiplication solve your issue?

#8

Sure thing, here’s the issue I’ve been having.

#9

I did try that, but got a message saying “Hardware Shader is broken on Mac” and when I enabled it it just gave me a black screen when launching the game.

#10

So, I think the problem might have something to do with this issue, with the shadow pipeline. However, using the old version causes a lot of stutter during the gameplay, which I don’t get with the newer one, so I’m kind of at a loss here.

#11

Just wanted to ask again if anyone knew how to fix this, I still can’t figure it out, sadly.