Shin megami tensei 4 at super speed

Issue:
Just upgraded my gpu and now smtiv runs really fast, even though I have limit speed percent set to 100%

System Information

  • Operating System: window 7 64 bit
  • CPU: Amd A8
  • GPU: Gtx 970
  • Citra Version (found in title bar): nightly #995
  • Game: Shin megami tensei 4 (us)
  • Screenshot of Issue (include the full Citra window including titlebar):
    not needed (though I might upload a video if it is necessary)

EDIT: on further inspection it seems to happen on all games

Diagnostic Log
citra_log.txt (67.7 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

take a screenshot of the entire screen while a game is presenting this issue.

Hmm. The games shows the speed to be below the max, but the sounds at least are in fast forward:


I also recorded a video, fps goes even slower here since I still haven’t upgraded my ram, but you can clearly hear the squeaky sped up voices.

There is definitely a weird pitch on the voices, akin to a sped up audio effect. is there a point where the framerate is 100% stable and the voices still present this issue?

btw, enable ‘Enable Hardware Shader’, it should work well with a Nvidia GPU.

also try to disable ‘Enable audio stretching’ on the System > Audio.

With enable hardware shader on it goes up to 90-100%, great!
Audio/ Output engine was set to sdl, changed it to auto and now it seems to work fine. Thanks!