Shin Megami Tensei Devil Survivor 2 Record Breaker - Naming Issue


#1

Issue
The game runs pretty well, but as soon as one is prompted to give their name, the game does not allow any. Even simple things like AAAAAA are dismissed. I am not sure if this is a problem with the rom or the Citra. So I will ask here, as well. Perhaps someone knows an answer to resolve this issue.

System Information

  • Operating System: Windows 10

  • CPU: AMD A8-6600K APU with Radeon™ HD Graphics 3.90 GHz

  • System Type 64-Bit Processor

  • Citra Version (found in titlebar): (not sure if this is it) Citra / HEAD-327692e

  • Game: Shin Megami Tensei Devil Survivor 2 Code Breaker

  • Screenshot of Issue

In the Naming Screen Menu

Log:
I can’t add a log. Even with the Guide, the log file in my folder is always empty :confused:
I hope the screenshots might be enough for this, though ^^;


#3

You’re using a very outdated Nightly build. Try updating to the most recent build. However, Citra requires you to own a 3DS and have dumped your system files, as most games require them anyway.

Also, how are you not able to produce a log file? Are you following the correct guide? There are two guides. One for the Nightly, and one for the Bleeding Edge.


#4

I already did dump my system files :confused:

I also did both guides, but the log is always empty. I am not sure why, though.
It’s hard to mess that up, after all :frowning:

I now use the newest build (HEAD-c04062c), but the same problem occures constantly… …
I tried the previous title “Devil Summoners Overclocked”, as well, but there the issue is not happening in the naming menu :confused:

Could this be a game related issue?


#6

You followed the guide to the dot? You have to close out of the game, and Citra for the log file to finish writing.
Also, perhaps you dumped your game incorrectly? You could try re-dumping the game. The game functions perfectly on my end.


#7

I had this same issue, resolved it by using an unofficial build at the time (6 months ago).

Later I just updated Citra to its latest version and it worked like a charm


#8

Dump your system files in the correct Citra folder.
If you upgrade from older version there might be folders in both local and roaming.


#9

Thanks for the help!
Now it is working!

I dumbed the system files in the right folder, but my shortcut went to another version of citra. I didn’t realize I had two on the PC! XD

Darn, I am a scatterbrain sometimes xD