Shin Megami Tensei IV Apocalypse texture problems

Issue: I don’t know since what version, but SMTIV:Apoc lately have some Texture issues as in some of them not being loaded properly and Mido doesn’t have a face nor his blue clothing, you only see him in total white. Also the game seem to run worse then the last time I played which was quite some time ago (Roughly around nightly 900ish If I can recall correctly).

System Information

  • Operating System: Windows 10 Pro x64
  • CPU: AMD Ryzen 5 1600x
  • GPU: AMD Radeon RX Vega 64
  • Citra Version (found in title bar): Citra Nightly 1315
  • Game: Shin Megami Tensei IV Apocalypse
  • Screenshot of Issue (include the full Citra window including titlebar): https://imgur.com/a/XWTlZKJ

Diagnostic Log
citra_log.txt (170.3 KB)

System Information for Support

Client Version                                Nightly 1315 HEAD-45ff10c
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon RX Vega
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try disabling ‘Accurate Multiplication’ and/or ‘Accurate Geometry Shaders’ or disable ‘Enable Hardware Shader’, see if that has any effect.

Well it seems to have to do with Hardware Shader (OGL) This issue wasn’t there at first so Citra changed something OpenGL wise. Though turning on Hardware shader is faster and makes the game stays at 30 fps more often then when turned off.

Do you remember when this issue wasn’t present? maybe you can find which update cause this bug.

You can find previous canary and nightly builds here and here. try out a build from around when (if you can remember) this issue wasn’t present. just download, extract to a (any) folder and launch citra-qt.exe.

No offense, but I’m not going to try 100s of versions to find which one is the one that provides the issue. Also I wrote already that I don’t remember when I last played it and it was playable with no texture issues.

System Information for Support

Client Version                                Nightly 1315 HEAD-45ff10c
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon RX Vega
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Well it will only be a few if you do a “binary search” algorithm.
Example:

Nightly 1315 - doesn’t work
Nightly 815 - works

Then the issue lies between these two builds so you take a build that is right at the center, e.g Nightly 1065.
If 1065 doesn’t work either then it would be between 1065 and 815 or if 1065 did work then it’s between 1315 and 1065 instead - then you just repeat this process until you have 2 builds left where one is working and the other doesn’t.
You can easily find builds by modifying the URL:
https://github.com/citra-emu/citra-nightly/releases?after=nightly-1064
https://github.com/citra-emu/citra-nightly/releases?after=nightly-814
etc.

But since you have AMD GPU, if the issue looks like this: https://www.reddit.com/r/Citra/comments/cdrlld/omega_ruby_the_shadows_appear_all_white_whenever/
Then rerolling drivers back to 19.4.3 seems to fix it - blame AMD.

I added a picture (link) in the first post. Also when fighting enemies when for example you hit one with fire it incinerates, but instead of having a transparent layer it’s black. Driver wise I’m at 19.6.2 atm so I don’t even have the latest version installed.

Also the outside world should be darker and not so bright see picture I added: https://imgur.com/a/41SO0r7

The issue with drivers started in like 19.5.1 iirc.

You might need to run DDU first:

Well the texture issues are gone now so indeed 19.4.3 is the fix, besides that there are still black squares when you kill someone with fire, ice, lightning or wind (Background of the monster).

Yeah it has been reported: https://github.com/citra-emu/citra/issues/2272

2.5 yrs and still not fixed? Dang guess it’s a minor issue, but still :slight_smile:

1 Like