Significant Input Lag and Unresponsive Window after minutes of normal gameplay

Issue:
My emulator runs smoothly for around 2 minutes and then begins to take inputs incredibly slowly, and the drop down menus (files, emulation etc.) are incredibly unresponsive and take several seconds to respond to a mouse click. Fullscreening/Swapping screens with F11 and F10 also take up to a minute, occasionally causing the window to be unresponsive (though they manage to recover after waiting for minutes).

The emulation sometimes recovers from this after several minutes - other times it does not, and requires a restart.

I should also note that the emulator consistently shows a 100% speed, frames running at an acceptable rate and the display working mostly fine, except when the window is unresponsive.

During the 2 minutes prior to this issue happening, the emulator runs perfectly fine.

System Information

  • Operating System: Linux Manjaro (KDE plasma)
  • CPU: AMD Ryzen 5 4000
  • Citra Version: citra-git r9163.ac98458e0-1
  • Game: Fire Emblem Awakening
  • Screenshot of Issue (include the full Citra window including titlebar):

Screenshot_20220326_154850|690x389

Diagnostic Log
citra_log.txt (46.7 KB)

System Information for Support

Client Version                               master-ac98458e0
Operating System                             Manjaro Linux
CPU                                          AMD Ryzen 5 4500U with Radeon Graphics          | AVX2 | FMA
Graphics API                                 OpenGL 4.6
Graphics Renderer                            AMD RENOIR (DRM 3.42.0, 5.15.28-1-MANJARO, LLVM 13.0.1)
GPU Driver Version                           Mesa 21.3.7
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

(I should mention that this did not help. I have tried both settings and they have not resolved the issue. Mii data is irrelevant, the game I am playing does not have Miis)

You should enable Hardware Shaders in Emulation>Configuration>Graphics>Advanced Tab.
Though I’m not sure why that would cause a slowdown of the UI itself.