Slow 50% on FE Fates

Issue:
FE Fates is running at 40% speed

System Information

  • Operating System: Windows 10
  • CPU: Ryzen 5 3600, 6 cores - 12cpu 3.6ghz
  • GPU: Radeon RX 570 Series
  • Citra Version (found in title bar): 1714
  • Game: Fire Emblem Fates special edition
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (70.5 KB)

System Information for Support

Client Version                                Nightly 1714 HEAD-5241032
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            21.6.1 27.20.22001.14011
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

citra_log.txt (84.7 KB)

System Information for Support

Client Version                                Nightly 1714 HEAD-5241032
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            21.6.1 27.20.22001.14011
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

what this bot is talking about, OpenGL 4.6 u can see it on this screen shot

citra_log.txt (198.2 KB)

System Information for Support

Client Version                                Nightly 1714 HEAD-5241032
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            21.6.2 27.20.22001.16006
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

How to optimize it better then plz ? help me :frowning: the character creation and starting video il working well but ingame it still 40% speed

Citra targets OpenGL 3.3 so that is why it says it in the log.

You can try turn off Hardware Shader in the Advanced graphics settings in Citra configuration and see if that helps. If not, you will most likely need to dual boot Linux (e.g Ubuntu) to gain ~3x more performance as the drivers there are better for Radeon for OpenGL applications.

Last option is to change graphics card to Nvidia. I’ve heard prices are starting to go down so maybe in the near future it will be possible to get one at a sane price. Maybe an RTX 3060 or something.

Sorry for the inconvenience.