Smash 2x Internal Resolution lag

#1

Issue:
When i choose 2x resolution or higher, my game lags. It only happens with Smash bros.
Tried nightly but its the same

System Information

  • Operating System: Windows 10 1809
  • CPU: i3-6100
  • GPU: GTX 1060 3GB
  • Citra Version (found in title bar): 1207
  • Game: Super Smash Bros for 3DS
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (197.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

System Information for Support

Enable CPU JIT                                [x]
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [x]
Enable Vsync                                  [ ]
LLE Audio Emulation Enabled                   [ ]
Use GDB Stub                                  [ ]
System Region                                 2
OpenGL Version                                3.3.0
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1060 3GB/PCIe/SSE2

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended for accurate emulation.
#3

Take a look at this PR, it explains the motivation for that hack but it was removed after canary-1041, from my testings SMB4 was one of those games that would benefit from it, in this case with higher internal resolution with performance degradation.

You can read there why it was removed, you can also test the canary build mentioned above to see if that works for you to.

#4

Thanks, now I understand why that happens and that its not a problem on my end. The build you posted works great, but i like using the latest version, so I’ll stick with it.