Smash Bros 3DS Mutliplayer Disconnect

Issue:
So I read about how to get multiplayer working in Citra, so me and my cousin wanted to play Smash 3DS over the internet. We both have copies of the US version of the game with update 1.1.6 and DLC, and we used a public lobby to connect. The game works perfectly fine till we get to the waiting stage (the one with the sandbag), but then if L+R is pressed to initiate the match, my end remains on the stage for a while after which I get a message saying “Connection with the other players has been lost”; meanwhile my cousin’s end goes completely black with just the music playing. We have tried switching around who creates the room but regardless of who the host is, my cousin’s screen will always go black (while I get the error message in a while). My cousin has a PC nearly identical to mine except for his GPU, which is an Nvidia GeForce GTX 1650 (Mobile), and his OS, which is Windows 10. We also have set identical configurations for the graphics. Also, we have tried using both Canary and Nightly builds (neither worked).

System Information

  • Operating System: Ubuntu 20.04.1 LTS
  • CPU: AMD Ryzen 5 3550H with Radeon Vega Gfx
  • GPU: AMD Radeon RX 560X (Mobile)
  • Citra Version (found in title bar): Nightly 1629, Canary 1865
  • Game: Super Smash Bros. for Nintendo 3DS

Diagnostic Log
citra_log.txt (4.5 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Make sure both of you run the same version of the game, e.g in this case 1.1.6.

We absolutely do. We even installed the EXACT same CIAs.

I see, then I’m not sure. I haven’t tested myself, I have 1.1.7 though.

Unfortunately, 1.1.7 seems to break certain characters, thus we went with 1.1.6. I have heard the EU version works on 1.1.7, but will my saves be compatible?

Sorry for the bump but does anyone have any idea?

I’m not sure if it would be worth for both of you to buy your own copies of the EU version when you already have US. Which you must do, otherwise it would be piracy which is illegal.

I mean yeah but even then it isn’t guaranteed right? Also I was wondering could it be due to us using different OSes?

Yeah it is not guaranteed to work.

I am not sure, it shouldn’t be any different.

You can try optimize your networks by like changing to Ethernet if you are using WiFi, change DNS to like Google’s or Cloudflare’s.

https://lifehacker.com/block-malware-with-cloudflares-new-dns-options-1842646761
https://developers.google.com/speed/public-dns/docs/using#change_your_dns_servers_settings

My network seems to be strong, although I haven’t checked with my cousin. I’ll do that.

Ok I was able to solve the issue. Turns out my stupid cousin was going into the wrong local play (multi man smash thingy).

1 Like

Ok so I know the issue is solved, but when using public servers, we were getting really bad pings and thus heavy input lag, so I wanted to make my own room (via citra). The thing is I never got port forwarding to work. If someone could help me out with what settings are being entered incorrectly, I would really appreciate it. I have a TP-Link router and followed their guide on port forwarding but didn’t work. Also there are additional settings like port triggering, UPnP, DMZ; so if someone could clarify if I needed to tinker with those settings as well it would really help (below is the screenshot of the router page).

Okay so I just read up online that I might be behind another router (used by my ISP). So unless I figure that out, an alternative option to get hosting a room and someone else connected to it would be using a VLAN through a software like Hamachi. I’m going to test that and check if it works.

And I was right. Using hamachi allowed me to host my own room and allow my cousin to connect. Latency has been severely reduced. I can once again enjoy smash like I used to before my 3DS stopped working lol.

1 Like