Smash ultimate crashes when picking a character

I just dumped everything for the first time and launched ultimate on yuzu without dlc and everything worked fine. However, when I added updates (up to sora with full dlc, crashes regardless if dlc is enabled and changing from open gl to vulcan has no effect), the game will crash the moment I pick anyone at character select. I think I dumped the update/dlc stuff wrong but I have no clue. Does anyone have a fix? yuzu_log.txt (1.4 MB)

Can you try disabling asynchronous shaders in config graphics advanced? As well see if updating to Geforce Driver Results | NVIDIA helps any. Only other thing I can think about is if you had previously tried to mod the game and not disabled the SDMC or removed the UMM based mods you might have tried.

If you suspect it is the update - dlc’s themselves you can try redumping it and applying it back to yuzu nand to help you rule out corruption.

Tried turning off async shaders and updating drivers and it still crashes (I got more fps from the driver update tho lol). I never installed mods.

yuzu_log.txt (2.4 MB)

I’ll redump tomorrow and keep you posted, only thing I’m concerned about is whether or not I made a copy of something I shouldn’t have. My DLC files should be 1-12, 21-22, and 43, right?

No rush. Depends how many you bought into but yeah it should show multiple listings under the game addons that you installed. Smash is kind of odd for its dlc name-numbering scheme :stuck_out_tongue:

I never redumped anything, but I found the problem: my save data. It’s not a bad dump because it worked fine on unpatched, so I have no clue what could’ve caused it unless yuzu did something to my save when I played on 1.0.0. I’ll have to re-unlock characters which sucks so much, but at least it works now. Maybe I could get another save file online, but ehh. Hope people who look this up on google find this helpful lol.

Edit: I got a save off the smash yuzu discord and it works great!

1 Like

tysm!!! that was my exact cause as well! which is a shame on the other side, because my “broken” specific save was from my main Switch (using EdiZon), i was planning to move all of my data on yuzu but it seems not all games like Smash 5 likes that. i just had to replace system_data.bin to something else so i didn’t lose everything such as custom stages, miis and maybe spirits

update 1: after changing some settings and customizing my game the problem has returned. wtf??? so the only fix is by deleting my save data every time?
update 2: i use Vulkan instead of OpenGL and i tried to switch to OpenGL. it didn’t crash after trying 2 matches! i’ll edit this comment again if this problem will persist, so my 2nd suggestion would be to switch your API to OpenGL if you’re running yuzu with Vulkan…