SMT Soul Hackers unplayable

Issue:
So, I know that my PC is pretty bad, but I’ve played and finished literally all others SMT 3ds games (SMT IV, Apocalypse, Redux, Devil Survivor 1, Devil Survivor 2, Persona Q1 and Persona Q2) and all of them worked perfect fine, but this one, Soul Hackers, have a massive FPS drop in exploration and battles, playing at 40% speed, making it unplayable. I want to know if is possible to fix this issue somehow, or if I need a high end PC to play this one, or if this game works at all in any PC… I don’t even understand how is possible to play Persona Q2, but not this one in this PC
Also, I can’t use more recent Citra versions, because they make games random crash for me, only the 1392 is compatible
Thanks in advance

System Information

  • Operating System: Windows 10
  • CPU: Intel ® Core ™ i5-3317U CPU @ 1.70GHz 1.70 GHz
  • GPU: Intel HD Graphics 4000
  • Citra Version (found in title bar): Citra Nightly 1392
  • Game: SMT Soul Hackers
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (324.9 KB)

System Information for Support

Client Version                                Nightly 1392 HEAD-ddb7ead
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.5161
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
[ 205.520299] Render.OpenGL <Warning> video_core/renderer_opengl/renderer_opengl.cpp:DebugHandler:764: SHADER_COMPILER OTHER 0: GLSL compile warning(s) for shader 1, "": WARNING: 1:2: '#extension' :  'GL_ARB_shader_image_load_store' is not supported
WARNING: 1:3: '#extension' :  'GL_ARB_shader_image_size' is not supported

^ This is the only thing that stands out from your log file and this is simply referring to your GPU’s OpenGL drivers not having all the necessary extensions. Which is why you’re using Nightly 1392 in the first place. No idea if this is causing the performance issues though. Considering that you’re on an older Citra version, you can’t use the CPU Clock Speed modifier to test out whether this is a scheduling issue either. So I’m just gonna say that this is most likely an issue with your PC being too old.

I see, thanks for the reply o/