SMT4 Apocalypse crash on choosing to look for relics

Issue:
Game starts and runs normally until you are prompted to look for relics which triggers a shift to a 3d area citra then fills the log with purple entry’s and crashes

System Information

  • Operating System: win 10 64bit
  • CPU: i7-7200u
  • GPU: nvidea gtx 950M (open gl 4.4 according to the specs)
  • Citra Version (found in title bar): HEAD-5f2dfb4 (canary)
  • Game: smt 4 apocalypse
  • Screenshot of Issue (i

cant put my log into the window says there are too many characters nor can i attach it as i am a new person so i will copy in the (assumed relevant) part

video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type 2
[ 359.521054] HW.GPU
video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type 2
[ 361.216517] HW.GPU
video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type 2
[ 361.216537] HW.GPU
video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type 2
[ 361.238615] HW.GPU
video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type 2
[ 361.238636] HW.GPU
video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type 2
[ 361.251807] HW.GPU
video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type 2
[ 361.251832] HW.GPU
video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type 2
[ 361.267669] HW

in another thread i saw someone say that new versions dont get this error it seems that they do or the updater is not updating very well at all :stuck_out_tongue:

if you want the full log and can think of a way for me to post it i’ll oblige same for the screenshot of the issue without the paint window in the way.

*edit i dont need help with the paint window >.< before people start getting really helpful

Can you test this on nightly?

I can indeed latest update i assume using the updater maintenance tool i’ll have a log and screenshot in half hour or so after i crash it again

it crashed again same stuff in the log i cant find a way to attach the log so here is an a part of it from when the crash occurs

[ 203.323233] Service.Y2R core/hle/service/y2r_u.cpp:SetTransferEndInterrupt:250: (STUBBED) called
[ 203.388215] Service.Y2R core/hle/service/y2r_u.cpp:SetTransferEndInterrupt:250: (STUBBED) called
[ 203.389539] Service.Y2R core/hle/service/y2r_u.cpp:SetTransferEndInterrupt:250: (STUBBED) called
[ 203.458901] Service.Y2R core/hle/service/y2r_u.cpp:SetTransferEndInterrupt:250: (STUBBED) called
[ 203.460675] Service.Y2R core/hle/service/y2r_u.cpp:SetTransferEndInterrupt:250: (STUBBED) called
[ 203.553748] Audio.DSP audio_core/hle/pipe.cpp:PipeWrite:140: Application has requested shutdown of DSP
hardware
[ 203.553777] Service.DSP core/hle/service/dsp_dsp.cpp:RegisterInterruptEvents:253: Unregistered interrupt=2,
channel=2, event_handle=0x00000000
[ 203.553794] Service core/hle/service/service.cpp:HandleSyncRequest:96: unknown / unimplemented function
‘UnloadComponent’: port=dsp::DSP
[ 203
.553903] Service.DSP core/hle/
service/dsp_dsp.cpp:LoadComponent:148: Firmware hash: 0x943f5565dbcf6767
[ 203.553933] Service.DSP core/hle/service/dsp_dsp.cpp:LoadComponent:152: Structures hash: 0x93e48663943cad39
[ 203.553938] Service.DSP core/hle/service/dsp_dsp.cpp:LoadComponent:157: (STUBBED) called size=0xC25C,
prog_mask=0x000000FF, data_mask=0x001100FF, buffer=0x005B4824
[ 203.553954] Service.DSP core/hle/service/dsp_dsp.cpp:RegisterInterruptEvents:248: Registered type=2, pipe=2,
event_handle=0x0012005A
[ 203.553963] Service.DSP core/hle/service/dsp_dsp.cpp:GetSemaphoreEventHandle:174: (STUBBED) called
[ 203.553971] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphoreMask:469: (STUBBED) called mask=0x00002000
[ 203.553980] Audio.DSP audio_core/hle/pipe.cpp:PipeWrite:134: Application has requested initialization of DSP
hardware
[ 203.553989] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphore:271: (STUBBED) called
[ 203.554024] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphore:271: (STUBBED) called
[ 285.986586] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2
[ 285.986629] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2
[ 286.004913] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2
[ 286.004944] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2
[ 286.031851] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2
[ 286.031877] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2
[ 286.048855] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2
[ 286.048879] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2
[ 286.069065] HW.GPU video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:206: Unhandled texture type
2

it carry’s on with the texture type 2 purple error till it closes

was that any use for you ?

Please make an issue, including the log you got on Nightly.

thats done and posted now : https://github.com/citra-emu/citra/issues/3285

thanks for the help

1 Like