SMT4 Apocalypse Speed Issue

Enter a description of your issue here, in full detail.

The problem here is that whenever I go into that shop, the game would slow down and my cpu usage would increase from 8% to 21%, it would be “fixed” if i randomly pick another resolution, regardless of how big or small it is.
(Video: SMT IV Apocalypse Citra slowdown issue - YouTube)
1. I set this to unlimited frames so that the problem can be shown in a more apparent manner. The
problem persists even when I lock my fps.
2. This problem exists in both builds of Citra
3. I don’t think this is my hardware issue as I can increase my res and it still runs perfectly
4. I don’t know whether this problem exists further into the game, this is the only place I have experienced that happens
5. Neither do I think it is my rom’s issue as I got this straight from my own 3ds

System Information

  • Operating System: Windows 10
  • CPU: i7-7700k
  • GPU: nVidia GTX 970
  • Citra Version (found in title bar): Canary 2142
  • Game: SMT IV Apocalypse
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (325.6 KB)
In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

System Information for Support

Client Version                               Canary 2143   HEAD-e5b9c95
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            NVIDIA GeForce GTX 970/PCIe/SSE2
GPU Driver Version                           512.77
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Is there any reason you have Dump Textures turned on? If you are not dumping them for a purpose such as making your own texture pack, please disable these in Emulation > Configure > Graphics then upload another log file.

2 things

1.I am Sorry that I cross-posted. I waited so long without a response, and I got very impatient, plus I didn’t know about the discord. I won’t do it next time, thanks for the reminder and kind response.
2. I tried disabling it and its SO MUCH BETTER. Thank you my friend1 I initially dismissed it as it doesn’t seem to do anything lol. Once again thank you