Sneaking in Omega Ruby using X360 gamepad

Issue:
I know there are many issues on it, but every thing i tried does not work.

System Information

  • Operating System: Win 10 pro 64bit
  • CPU: Ryzen 5 2600x
  • GPU: msi geforce gtx 1060 6gb
  • Citra Version (nightly 1623):
  • Game: Pokemon omega ruby
  • Screenshot of Issue

Diagnostic Log
citra_log.txt (560.6 KB)

System Information for Support

Client Version                                Nightly 1623 HEAD-a576eb6
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2600X Six-Core Processor           
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1060 6GB/PCIe/SSE2
GPU Driver Version                            441.66
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Did you use Set Analog Stick?

Yes I did… and that done nothing as well

Open joy.cpl (Do a simple Windows search, it is the Windows gamepad settings) and double check that your controller behaves correctly there, you might need to go to the Settings tab and calibrate your controller.

I’m using a PS3 controller which is emulating a X360 controller and it works fine here.

The Set Analog Stick option in Citra ensures you will get full 360 degrees movement and be able to lightly tilt to move slower. If you would click on a four directions manually you would be locked to 8 fixed directions which is not smooth at all.